Every CVE Search/ Get API key

CVE-2023-5540

Moodle: authenticated remote code execution risk in imscp

4.7 MediumFix available

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

2.27%Up 2.2 points since Nov 10, 2023
90%50%10%1%

What each source reports

CVE List Score used 4.7

Moodle: authenticated remote code execution risk in imscp

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Record
CVE-2023-5540
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2023-3049 4.7

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Record
EUVD-2023-3049
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-w8x2-w4qr-v3x4 8.8

Moodle Code Injection vulnerability

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Record
GHSA-w8x2-w4qr-v3x4
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
NVD 4.7

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Record
CVE-2023-5540
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV 4.7

Moodle: authenticated remote code execution risk in imscp

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Record
CVE-2023-5540
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-94
Updated
2026-11-02
OSVGHSA-w8x2-w4qr-v3x4 8.8

Moodle Code Injection vulnerability

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Record
GHSA-w8x2-w4qr-v3x4
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSVUBUNTU-CVE-2023-5540 4.7

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Record
UBUNTU-CVE-2023-5540
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-moodle-2023-5540 No score

Moodle: authenticated remote code execution risk in imscp

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Record
BIT-moodle-2023-5540
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 4.3.0-rc2
4.3.0-rc2
moodle
Bitnami
before 3.9.24, 3.11.0 up to 3.11.17, 4.0.0 up to 4.0.11, 4.1.0 up to 4.1.6, 4.2.0 up to 4.2.3
3.9.243.11.174.0.114.1.64.2.3
moodle/moodle
Packagist
before 4.3.0-rc2, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
4.3.0-rc2
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-5540 is a medium vulnerability (CVSS 4.7) in Moodle, published November 9, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.27%, the 83rd percentile. Fixed in moodle/moodle 4.3.0-rc2.

References

Show 5 moreShow less
This page doesn't list everything

Left out here: 322 versions. The JSON record has them.

MoveEnter Open