CVE-2023-5550
Moodle: rce due to lfi risk in some misconfigured shared hosting environments
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Moodle: rce due to lfi risk in some misconfigured shared hosting environments
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
- Record
CVE-2023-5550- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2023-2887
6.5
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
- Record
EUVD-2023-2887- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5cvx-cwpx-9rjh
6.5
Moodle Code Injection vulnerability
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
- Record
GHSA-5cvx-cwpx-9rjh- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
NVD
6.5
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
- Record
CVE-2023-5550- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
6.5
Moodle: rce due to lfi risk in some misconfigured shared hosting environments
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
- Record
CVE-2023-5550- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-5cvx-cwpx-9rjh
6.5
Moodle Code Injection vulnerability
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
- Record
GHSA-5cvx-cwpx-9rjh- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-5550
6.5
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
- Record
UBUNTU-CVE-2023-5550- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-moodle-2023-5550 No score
Moodle: rce due to lfi risk in some misconfigured shared hosting environments
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
- Record
BIT-moodle-2023-5550- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
4.3.0-beta up to 4.3.0-rc2 | 4.3.0-rc2 |
moodle/moodlePackagist |
4.2.0 up to 4.2.3 | 4.2.3 |
moodle/moodlePackagist |
4.1.0 up to 4.1.6 | 4.1.6 |
moodle/moodlePackagist |
4.0.0 up to 4.0.11 | 4.0.11 |
moodle/moodlePackagist |
3.10.0 up to 3.11.17 | 3.11.17 |
moodle/moodlePackagist |
before 3.9.24 | 3.9.24 |
moodleBitnami |
before 3.9.24, 3.11.0 up to 3.11.17, 4.0.0 up to 4.0.11, 4.1.0 up to 4.1.6, 4.2.0 up to 4.2.3 | 3.9.243.11.174.0.114.1.64.2.3 |
moodle/moodlePackagist |
4.3.0-beta up to 4.3.0-rc2, plus listed versions v4.3.0-betav4.3.0-rc1 |
4.3.0-rc2 |
moodle/moodlePackagist |
4.2.0 up to 4.2.3, plus listed versions v4.2.0v4.2.1v4.2.2 |
4.2.3 |
moodle/moodlePackagist |
4.1.0 up to 4.1.6, plus listed versions v4.1.0v4.1.1v4.1.2v4.1.3v4.1.4v4.1.5 |
4.1.6 |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
4.0.0 up to 4.0.11, plus listed versions v4.0.0v4.0.1v4.0.10v4.0.2v4.0.3 Show 6 moreShow lessv4.0.4v4.0.5v4.0.6v4.0.7v4.0.8v4.0.9 |
4.0.11 |
moodle/moodlePackagist |
3.10.0 up to 3.11.17, plus listed versions v3.10.0v3.10.1v3.10.10v3.10.11v3.10.2 Show 27 moreShow lessv3.10.3v3.10.4v3.10.5v3.10.6v3.10.7v3.10.8v3.10.9v3.11.0v3.11.0-betav3.11.0-rc1v3.11.0-rc2v3.11.1v3.11.10v3.11.11v3.11.12v3.11.13v3.11.14v3.11.15v3.11.16v3.11.2v3.11.3v3.11.4v3.11.5v3.11.6v3.11.7v3.11.8v3.11.9 |
3.11.17 |
moodle/moodlePackagist |
before 3.9.24, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 45 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1 |
3.9.24 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-5550 is a medium vulnerability (CVSS 6.5) in Moodle, published November 9, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.62%, the 76th percentile. Fixed in moodle/moodle 4.3.0-rc2.
References
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72249
bugzilla.redhat.com/show_bug.cgi?id=2243452
moodle.org/mod/forum/discuss.php?d=451591
nvd.nist.gov/vuln/detail/CVE-2023-5550
github.com/moodle/moodle/commit/77766f9c8af8fc8d861d7ac09ce4e1f6e72faca7
github.com/advisories/GHSA-5cvx-cwpx-9rjh
Left out here: 221 versions. The JSON record has them.