Every CVE Search/ Get API key

CVE-2023-6014

MLflow Authentication Bypass

9.1 CriticalFix available

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirment.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

1.17%Up 1.1 points since Nov 17, 2023
90%50%10%1%

What each source reports

CVE List Score used 9.1

MLflow Authentication Bypass

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirment.

Record
CVE-2023-6014
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-598
Updated
2026-11-02
EUVDEUVD-2023-2882 9.1

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirment.

Record
EUVD-2023-2882
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-4qq5-mxxx-m6gg 9.1

MLflow authentication requirement bypass can allow a user to arbitrarily create an account

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirement.

Record
GHSA-4qq5-mxxx-m6gg
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-598
Updated
2026-11-02
NVD 9.8

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirment.

Record
CVE-2023-6014
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-598
Updated
2026-11-02
OSVGHSA-4qq5-mxxx-m6gg 9.1

MLflow authentication requirement bypass can allow a user to arbitrarily create an account

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirement.

Record
GHSA-4qq5-mxxx-m6gg
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-598
Updated
2026-11-02
OSVPYSEC-2026-415 9.1

MLflow authentication requirement bypass can allow a user to arbitrarily create an account

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirement.

Record
PYSEC-2026-415
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVBIT-mlflow-2023-6014 No score

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirment.

Record
BIT-mlflow-2023-6014
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mlflow
PyPI
before 2.8.0
2.8.0
mlflow
Bitnami
Not stated
Not evaluated
mlflow
PyPI
before 2.8.0, plus listed versions
0.0.10.1.00.2.00.2.10.3.0
Show 45 moreShow less
0.4.00.4.10.4.20.5.00.5.10.5.20.6.00.7.00.8.00.8.10.8.20.9.00.9.0.10.9.11.0.01.1.01.1.1.dev01.10.01.11.01.12.01.12.11.131.13.11.14.01.14.11.15.01.16.01.17.01.18.01.19.01.2.01.20.01.20.11.20.21.21.01.22.01.23.01.23.11.24.01.25.01.25.11.26.01.26.11.27.01.28.0
2.8.0

Not evaluated means the source gave git commits or a range we can't read, so we can't tell which releases are affected. A fixed version beside it is the source’s own claim.

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-6014 is a critical vulnerability (CVSS 9.1) in Lfprojects Mlflow, published November 16, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.17%, the 67th percentile. Fixed in mlflow 2.8.0.

References

This page doesn't list everything

Left out here: 31 versions. The JSON record has them.

MoveEnter Open