CVE-2025-57106
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in...
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
- Record
CVE-2025-57106- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-122
- Updated
- 2026-11-02
EUVDEUVD-2025-37362
7.5
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
- Record
EUVD-2025-37362- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5pfc-43r5-qrmg
7.5
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in...
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
- Record
GHSA-5pfc-43r5-qrmg- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-122
- Updated
- 2026-11-02
NVD
7.5
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
- Record
CVE-2025-57106- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-122
- Updated
- 2026-11-05
OSV
7.5
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
- Record
CVE-2025-57106- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-57106
7.5
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
- Record
DEBIAN-CVE-2025-57106- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-06
OSVPYSEC-2025-224
7.5
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
- Record
PYSEC-2025-224- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-57106
7.5
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
- Record
UBUNTU-CVE-2025-57106- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vtk9Debian:12 |
All versions, plus listed versions 9.1.0+really9.1.0+dfsg2-59.1.0+really9.1.0+dfsg2-5+deb12u19.1.0+really9.1.0+dfsg2-69.1.0+really9.1.0+dfsg2-79.1.0+really9.1.0+dfsg2-7.1 Show 45 moreShow less9.1.0+really9.1.0+dfsg2-89.2.6+dfsg1-1+exp19.2.6+dfsg1-1+exp29.3.0+dfsg1-19.3.0+dfsg1-1.19.3.0+dfsg1-1~exp19.3.0+dfsg1-1~exp29.3.0+dfsg1-1~exp39.3.0+dfsg1-1~exp49.3.0+dfsg1-29.3.0+dfsg1-39.3.0+dfsg1-3+hurd.19.3.0+dfsg1-49.3.0+dfsg1-4+m68k9.3.0+dfsg1-4.1+hurd.19.3.0+dfsg1-59.3.0+dfsg1-69.3.0+dfsg1-79.5.2+dfsg1-1~exp19.5.2+dfsg2-19.5.2+dfsg2-1~exp19.5.2+dfsg2-1~exp29.5.2+dfsg2-1~exp39.5.2+dfsg2-1~exp49.5.2+dfsg2-29.5.2+dfsg2-39.5.2+dfsg2-49.5.2+dfsg3-19.5.2+dfsg3-29.5.2+dfsg3-39.5.2+dfsg3-49.5.2+dfsg3-59.5.2+dfsg3-69.5.2+dfsg3-79.5.2+dfsg3-89.5.2+dfsg4-19.5.2+dfsg4-29.5.2+dfsg4-39.5.2+dfsg4-49.5.2+dfsg4-59.6.2+dfsg1-1exp19.6.2+dfsg1-1exp29.6.2+dfsg1-1exp39.6.2+dfsg1-1exp49.6.2+dfsg1-1exp5 |
None known |
vtk9Debian:13 |
All versions, plus listed versions 9.3.0+dfsg1-49.3.0+dfsg1-4+m68k9.3.0+dfsg1-4.1+hurd.19.3.0+dfsg1-59.3.0+dfsg1-6 Show 39 moreShow less9.3.0+dfsg1-79.5.2+dfsg1-1~exp19.5.2+dfsg2-19.5.2+dfsg2-1~exp19.5.2+dfsg2-1~exp29.5.2+dfsg2-1~exp39.5.2+dfsg2-1~exp49.5.2+dfsg2-29.5.2+dfsg2-39.5.2+dfsg2-49.5.2+dfsg3-19.5.2+dfsg3-29.5.2+dfsg3-39.5.2+dfsg3-49.5.2+dfsg3-59.5.2+dfsg3-69.5.2+dfsg3-79.5.2+dfsg3-89.5.2+dfsg4-19.5.2+dfsg4-29.5.2+dfsg4-39.5.2+dfsg4-49.5.2+dfsg4-59.6.2+dfsg1-1exp19.6.2+dfsg1-1exp29.6.2+dfsg1-1exp39.6.2+dfsg1-1exp49.6.2+dfsg1-1exp59.6.2+dfsg1-29.6.2+dfsg1-39.6.2+dfsg1-49.6.2+dfsg1-59.6.2+dfsg1-69.6.2+ds-19.6.2+ds-29.6.2+ds-2+test9.6.2+ds-2+test19.6.2+ds-39.6.2+ds-4 |
None known |
vtk9Debian:14 |
before 9.6.2+ds-1, plus listed versions 9.3.0+dfsg1-49.3.0+dfsg1-4+m68k9.3.0+dfsg1-4.1+hurd.19.3.0+dfsg1-59.3.0+dfsg1-6 Show 33 moreShow less9.3.0+dfsg1-79.5.2+dfsg1-1~exp19.5.2+dfsg2-19.5.2+dfsg2-1~exp19.5.2+dfsg2-1~exp29.5.2+dfsg2-1~exp39.5.2+dfsg2-1~exp49.5.2+dfsg2-29.5.2+dfsg2-39.5.2+dfsg2-49.5.2+dfsg3-19.5.2+dfsg3-29.5.2+dfsg3-39.5.2+dfsg3-49.5.2+dfsg3-59.5.2+dfsg3-69.5.2+dfsg3-79.5.2+dfsg3-89.5.2+dfsg4-19.5.2+dfsg4-29.5.2+dfsg4-39.5.2+dfsg4-49.5.2+dfsg4-59.6.2+dfsg1-1exp19.6.2+dfsg1-1exp29.6.2+dfsg1-1exp39.6.2+dfsg1-1exp49.6.2+dfsg1-1exp59.6.2+dfsg1-29.6.2+dfsg1-39.6.2+dfsg1-49.6.2+dfsg1-59.6.2+dfsg1-6 |
9.6.2+ds-1 |
vtkPyPI |
before 9.5.1, plus listed versions 8.1.08.1.18.1.29.0.09.0.1 Show 14 moreShow less9.0.29.0.39.1.09.2.29.2.49.2.59.2.69.3.09.3.19.3.20230807rc09.4.09.4.19.4.29.5.0 |
9.5.1 |
vtkUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 5.8.0-14ubuntu15.8.0-14ubuntu35.8.0-14.1ubuntu25.8.0-14.1ubuntu35.8.0-14.1ubuntu3+esm1 |
None known |
vtkUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 5.10.1+dfsg-25.10.1+dfsg-2build35.10.1+dfsg-2.1build15.10.1+dfsg-2.1ubuntu0.1~esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | OSV | |
| facts | NVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-57106 is a high vulnerability (CVSS 7.5) in Vtk, published October 31, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.43%, the 37th percentile. Fixed in vtk9 9.6.2+ds-1.
References
gitlab.kitware.com/vtk/vtk/-/issues/19733
gitlab.kitware.com/vtk/vtk/-/issues/19734
nvd.nist.gov/vuln/detail/CVE-2025-57106
github.com/advisories/GHSA-5pfc-43r5-qrmg
github.com/CVEProject/cvelistV5/tree/main/cves/2025/57xxx/CVE-2025-57106.json
security-tracker.debian.org/tracker/CVE-2025-57106
ubuntu.com/security/CVE-2025-57106
cve.org/CVERecord?id=CVE-2025-57106
Left out here: 11 versions. The JSON record has them.