Every CVE Search/ Get API key

CVE-2025-57107

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability...

7.1 HighFix available

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

0.18%Up 0.2 points since Nov 1, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.1

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Record
CVE-2025-57107
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-122
Updated
2026-11-02
EUVDEUVD-2025-37361 7.1

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Record
EUVD-2025-37361
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-6hj2-fxwr-rvj5 7.1

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability...

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Record
GHSA-6hj2-fxwr-rvj5
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-122
Updated
2026-11-02
NVD 7.1

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Record
CVE-2025-57107
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-122
Updated
2026-11-05
OSV 7.1

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Record
CVE-2025-57107
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2025-57107 7.1

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Record
DEBIAN-CVE-2025-57107
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-06
OSVPYSEC-2025-225 7.1

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Record
PYSEC-2025-225
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2025-57107 7.1

Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

Record
UBUNTU-CVE-2025-57107
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vtk9
Debian:12
All versions, plus listed versions
9.1.0+really9.1.0+dfsg2-59.1.0+really9.1.0+dfsg2-5+deb12u19.1.0+really9.1.0+dfsg2-69.1.0+really9.1.0+dfsg2-79.1.0+really9.1.0+dfsg2-7.1
Show 45 moreShow less
9.1.0+really9.1.0+dfsg2-89.2.6+dfsg1-1+exp19.2.6+dfsg1-1+exp29.3.0+dfsg1-19.3.0+dfsg1-1.19.3.0+dfsg1-1~exp19.3.0+dfsg1-1~exp29.3.0+dfsg1-1~exp39.3.0+dfsg1-1~exp49.3.0+dfsg1-29.3.0+dfsg1-39.3.0+dfsg1-3+hurd.19.3.0+dfsg1-49.3.0+dfsg1-4+m68k9.3.0+dfsg1-4.1+hurd.19.3.0+dfsg1-59.3.0+dfsg1-69.3.0+dfsg1-79.5.2+dfsg1-1~exp19.5.2+dfsg2-19.5.2+dfsg2-1~exp19.5.2+dfsg2-1~exp29.5.2+dfsg2-1~exp39.5.2+dfsg2-1~exp49.5.2+dfsg2-29.5.2+dfsg2-39.5.2+dfsg2-49.5.2+dfsg3-19.5.2+dfsg3-29.5.2+dfsg3-39.5.2+dfsg3-49.5.2+dfsg3-59.5.2+dfsg3-69.5.2+dfsg3-79.5.2+dfsg3-89.5.2+dfsg4-19.5.2+dfsg4-29.5.2+dfsg4-39.5.2+dfsg4-49.5.2+dfsg4-59.6.2+dfsg1-1exp19.6.2+dfsg1-1exp29.6.2+dfsg1-1exp39.6.2+dfsg1-1exp49.6.2+dfsg1-1exp5
None known
vtk9
Debian:13
All versions, plus listed versions
9.3.0+dfsg1-49.3.0+dfsg1-4+m68k9.3.0+dfsg1-4.1+hurd.19.3.0+dfsg1-59.3.0+dfsg1-6
Show 39 moreShow less
9.3.0+dfsg1-79.5.2+dfsg1-1~exp19.5.2+dfsg2-19.5.2+dfsg2-1~exp19.5.2+dfsg2-1~exp29.5.2+dfsg2-1~exp39.5.2+dfsg2-1~exp49.5.2+dfsg2-29.5.2+dfsg2-39.5.2+dfsg2-49.5.2+dfsg3-19.5.2+dfsg3-29.5.2+dfsg3-39.5.2+dfsg3-49.5.2+dfsg3-59.5.2+dfsg3-69.5.2+dfsg3-79.5.2+dfsg3-89.5.2+dfsg4-19.5.2+dfsg4-29.5.2+dfsg4-39.5.2+dfsg4-49.5.2+dfsg4-59.6.2+dfsg1-1exp19.6.2+dfsg1-1exp29.6.2+dfsg1-1exp39.6.2+dfsg1-1exp49.6.2+dfsg1-1exp59.6.2+dfsg1-29.6.2+dfsg1-39.6.2+dfsg1-49.6.2+dfsg1-59.6.2+dfsg1-69.6.2+ds-19.6.2+ds-29.6.2+ds-2+test9.6.2+ds-2+test19.6.2+ds-39.6.2+ds-4
None known
vtk9
Debian:14
before 9.6.2+ds-1, plus listed versions
9.3.0+dfsg1-49.3.0+dfsg1-4+m68k9.3.0+dfsg1-4.1+hurd.19.3.0+dfsg1-59.3.0+dfsg1-6
Show 33 moreShow less
9.3.0+dfsg1-79.5.2+dfsg1-1~exp19.5.2+dfsg2-19.5.2+dfsg2-1~exp19.5.2+dfsg2-1~exp29.5.2+dfsg2-1~exp39.5.2+dfsg2-1~exp49.5.2+dfsg2-29.5.2+dfsg2-39.5.2+dfsg2-49.5.2+dfsg3-19.5.2+dfsg3-29.5.2+dfsg3-39.5.2+dfsg3-49.5.2+dfsg3-59.5.2+dfsg3-69.5.2+dfsg3-79.5.2+dfsg3-89.5.2+dfsg4-19.5.2+dfsg4-29.5.2+dfsg4-39.5.2+dfsg4-49.5.2+dfsg4-59.6.2+dfsg1-1exp19.6.2+dfsg1-1exp29.6.2+dfsg1-1exp39.6.2+dfsg1-1exp49.6.2+dfsg1-1exp59.6.2+dfsg1-29.6.2+dfsg1-39.6.2+dfsg1-49.6.2+dfsg1-59.6.2+dfsg1-6
9.6.2+ds-1
vtk
PyPI
before 9.5.1, plus listed versions
8.1.08.1.18.1.29.0.09.0.1
Show 14 moreShow less
9.0.29.0.39.1.09.2.29.2.49.2.59.2.69.3.09.3.19.3.20230807rc09.4.09.4.19.4.29.5.0
9.5.1
vtk
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
5.8.0-14ubuntu15.8.0-14ubuntu35.8.0-14.1ubuntu25.8.0-14.1ubuntu35.8.0-14.1ubuntu3+esm1
None known
vtk
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
5.10.1+dfsg-25.10.1+dfsg-2build35.10.1+dfsg-2.1build15.10.1+dfsg-2.1ubuntu0.1~esm1
None known

History

History
RecordedChangedSources
affectedOSV
factsNVD
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-57107 is a high vulnerability (CVSS 7.1) in Vtk, published October 31, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.18%, the 7th percentile. Fixed in vtk9 9.6.2+ds-1.

References

This page doesn't list everything

Left out here: 11 versions. The JSON record has them.

MoveEnter Open