Every CVE Search/ Get API key

CVE-2026-40960

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least...

8.1 HighFix available

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.17%Up 0.2 points since Apr 16, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.1

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

Record
CVE-2026-40960
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-670
Updated
2026-11-02
EUVDEUVD-2026-23151 8.1

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

Record
EUVD-2026-23151
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-6v58-5584-rv99 8.1

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least...

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

Record
GHSA-6v58-5584-rv99
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-670
Updated
2026-11-02
NVD 8.1

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

Record
CVE-2026-40960
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-670
Updated
2026-11-02
OSV 8.1

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

Record
CVE-2026-40960
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-670
Updated
2026-11-02
OSVDEBIAN-CVE-2026-40960 8.1

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

Record
DEBIAN-CVE-2026-40960
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2026-40960 8.1

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

Record
UBUNTU-CVE-2026-40960
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2026-0185 No score

Updated minetest packages fix security vulnerabilities

Mod security sandbox escape. (CVE-2026-40959) HTTP API and insecure environment access control bypass. (CVE-2026-40960)

Record
MGASA-2026-0185
Updated
2026-11-02
OSVUSN-8366-1 No score

luanti vulnerabilities

It was discovered that Luanti, when using LuaJIT, did not properly enforce Lua sandbox restrictions. An attacker could possibly use this issue to execute arbitrary code. (CVE-2026-40959)

It was discovered that Luanti did not properly restrict access to insecure environments. An attacker could possibly use this issue to obtain unintended access to the insecure environment or HTTP API. (CVE-2026-40960)

Record
USN-8366-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
luanti
Debian:13
before 5.10.0+dfsg-5+deb13u1, plus listed versions
5.10.0+dfsg-5
5.10.0+dfsg-5+deb13u1
luanti
Debian:14
before 5.15.2+dfsg-1, plus listed versions
5.10.0+dfsg-55.14.0+dfsg-15.14.0+dfsg-25.14.0+dfsg-35.15.1+dfsg-15.15.1+dfsg-2
5.15.2+dfsg-1
minetest
Mageia:9
From an advisory covering 2 CVEs
before 5.7.0-1.1.mga9
5.7.0-1.1.mga9
luanti
Ubuntu:25.10
before 5.10.0+dfsg-5+deb13u1build0.25.10.1, plus listed versions
5.10.0+dfsg-5
5.10.0+dfsg-5+deb13u1build0.25.10.1
luanti
Ubuntu:26.04:LTS
before 5.10.0+dfsg-5+deb13u1build0.26.04.1, plus listed versions
5.10.0+dfsg-5
5.10.0+dfsg-5+deb13u1build0.26.04.1
luanti
Ubuntu:25.10
From an advisory covering 2 CVEs
before 5.10.0+dfsg-5+deb13u1build0.25.10.1, plus listed versions
5.10.0+dfsg-5
5.10.0+dfsg-5+deb13u1build0.25.10.1
luanti
Ubuntu:26.04:LTS
From an advisory covering 2 CVEs
before 5.10.0+dfsg-5+deb13u1build0.26.04.1, plus listed versions
5.10.0+dfsg-5
5.10.0+dfsg-5+deb13u1build0.26.04.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-40960 is a high vulnerability (CVSS 8.1) in Luanti, published April 16, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.17%, the 6th percentile. Fixed in luanti 5.10.0+dfsg-5+deb13u1.

References

Show 10 moreShow less
MoveEnter Open