CVE-2026-40960
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least...
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
- Record
CVE-2026-40960- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-670
- Updated
- 2026-11-02
EUVDEUVD-2026-23151
8.1
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
- Record
EUVD-2026-23151- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-6v58-5584-rv99
8.1
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least...
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
- Record
GHSA-6v58-5584-rv99- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-670
- Updated
- 2026-11-02
NVD
8.1
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
- Record
CVE-2026-40960- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-670
- Updated
- 2026-11-02
OSV
8.1
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
- Record
CVE-2026-40960- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-670
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-40960
8.1
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
- Record
DEBIAN-CVE-2026-40960- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-40960
8.1
Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.
- Record
UBUNTU-CVE-2026-40960- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2026-0185 No score
Updated minetest packages fix security vulnerabilities
Mod security sandbox escape. (CVE-2026-40959) HTTP API and insecure environment access control bypass. (CVE-2026-40960)
- Record
MGASA-2026-0185- Updated
- 2026-11-02
OSVUSN-8366-1 No score
luanti vulnerabilities
It was discovered that Luanti, when using LuaJIT, did not properly enforce Lua sandbox restrictions. An attacker could possibly use this issue to execute arbitrary code. (CVE-2026-40959)
It was discovered that Luanti did not properly restrict access to insecure environments. An attacker could possibly use this issue to obtain unintended access to the insecure environment or HTTP API. (CVE-2026-40960)
- Record
USN-8366-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
luantiDebian:13 |
before 5.10.0+dfsg-5+deb13u1, plus listed versions 5.10.0+dfsg-5 |
5.10.0+dfsg-5+deb13u1 |
luantiDebian:14 |
before 5.15.2+dfsg-1, plus listed versions 5.10.0+dfsg-55.14.0+dfsg-15.14.0+dfsg-25.14.0+dfsg-35.15.1+dfsg-15.15.1+dfsg-2 |
5.15.2+dfsg-1 |
minetestMageia:9 From an advisory covering 2 CVEs |
before 5.7.0-1.1.mga9 | 5.7.0-1.1.mga9 |
luantiUbuntu:25.10 |
before 5.10.0+dfsg-5+deb13u1build0.25.10.1, plus listed versions 5.10.0+dfsg-5 |
5.10.0+dfsg-5+deb13u1build0.25.10.1 |
luantiUbuntu:26.04:LTS |
before 5.10.0+dfsg-5+deb13u1build0.26.04.1, plus listed versions 5.10.0+dfsg-5 |
5.10.0+dfsg-5+deb13u1build0.26.04.1 |
luantiUbuntu:25.10 From an advisory covering 2 CVEs |
before 5.10.0+dfsg-5+deb13u1build0.25.10.1, plus listed versions 5.10.0+dfsg-5 |
5.10.0+dfsg-5+deb13u1build0.25.10.1 |
luantiUbuntu:26.04:LTS From an advisory covering 2 CVEs |
before 5.10.0+dfsg-5+deb13u1build0.26.04.1, plus listed versions 5.10.0+dfsg-5 |
5.10.0+dfsg-5+deb13u1build0.26.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-40960 is a high vulnerability (CVSS 8.1) in Luanti, published April 16, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.17%, the 6th percentile. Fixed in luanti 5.10.0+dfsg-5+deb13u1.
References
github.com/luanti-org/luanti/security/advisories/GHSA-22c4-238c-m5j4
github.com/luanti-org/luanti/commit/0faf529bc4b89e70a275ed1162047815118f2413
github.com/luanti-org/luanti/commit/827fd4cf7f989482b2dad381fa4afd642ea73e8c
nvd.nist.gov/vuln/detail/CVE-2026-40960
github.com/advisories/GHSA-6v58-5584-rv99
github.com/CVEProject/cvelistV5/tree/main/cves/2026/40xxx/CVE-2026-40960.json
Show 10 moreShow less
security-tracker.debian.org/tracker/CVE-2026-40960
advisories.mageia.org/MGASA-2026-0185.html
bugs.mageia.org/show_bug.cgi?id=35422
lists.fedoraproject.org/archives/list/[email protected]/message/2K6QTVDXSL7E72EYONNHDCY7I7LTD27B
lists.debian.org/debian-security-announce/2026/msg00127.html
github.com/luanti-org/luanti/security/advisories/GHSA-g596-mf82-w8c3
ubuntu.com/security/CVE-2026-40960
cve.org/CVERecord?id=CVE-2026-40960
ubuntu.com/security/notices/USN-8366-1
ubuntu.com/security/CVE-2026-40959