Every CVE Search/ Get API key

CVE-2009-4635

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary...

9.3 HighFix available

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted MOV container with improperly ordered tags that cause (1) mov.c and (2) utils.c to use inconsistent codec types and identifiers, leading to processing of a video-structure pointer by the mp3 decoder, and a stack-based buffer overflow.

Exploit likelihood

8.06%Down 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted MOV container with improperly ordered tags that cause (1) mov.c and (2) utils.c to use inconsistent codec types and identifiers, leading to processing of a video-structure pointer by the mp3 decoder, and a stack-based buffer overflow.

Record
CVE-2009-4635
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted MOV container with improperly ordered tags that cause (1) mov.c and (2) utils.c to use inconsistent codec types and identifiers, leading to processing of a video-structure pointer by the mp3 decoder, and a stack-based buffer overflow.

Record
CVE-2009-4635
Updated
2026-11-02
EUVDEUVD-2009-4600 No score

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted MOV container with improperly ordered tags that cause (1) mov.c and (2) utils.c to use inconsistent codec types and identifiers, leading to processing of a video-structure pointer by the mp3 decoder, and a stack-based buffer overflow.

Record
EUVD-2009-4600
Updated
2026-11-03
GitHub AdvisoriesGHSA-45r9-j9h4-w6jw No score

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary...

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted MOV container with improperly ordered tags that cause (1) mov.c and (2) utils.c to use inconsistent codec types and identifiers, leading to processing of a video-structure pointer by the mp3 decoder, and a stack-based buffer overflow.

Record
GHSA-45r9-j9h4-w6jw
Weakness
CWE-94
Updated
2026-11-02
OSV No score

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted MOV container with improperly ordered tags that cause (1) mov.c and (2) utils.c to use inconsistent codec types and identifiers, leading to processing of a video-structure pointer by the mp3 decoder, and a stack-based buffer overflow.

Record
CVE-2009-4635
Updated
2026-11-02
OSVDEBIAN-CVE-2009-4635 No score

FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted MOV container with improperly ordered tags that cause (1) mov.c and (2) utils.c to use inconsistent codec types and identifiers, leading to processing of a video-structure pointer by the mp3 decoder, and a stack-based buffer overflow.

Record
DEBIAN-CVE-2009-4635
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Debian:12
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg
Debian:13
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg
Debian:14
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg-debian
Debian:5.0
From an advisory covering 9 CVEs
before 0.svn20080206-18+lenny1, plus listed versions
0.svn20080206-160.svn20080206-170.svn20080206-17+lenny10.svn20080206-18
0.svn20080206-18+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4635 is a high vulnerability (CVSS 9.3) in Ffmpeg, published February 10, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.06%, the 94th percentile. Fixed in ffmpeg 4:0.5+svn20090706-3.

References

Show 13 moreShow less
MoveEnter Open