Every CVE Search/ Get API key

CVE-2013-3239

phpMyAdmin Remote Code Execution

4.6 MediumPublic exploitFix available

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Exploit likelihood

8.75%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Record
CVE-2013-3239
CVSS 2.0
4.6 MediumAV:N/AC:H/Au:S/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Record
CVE-2013-3239
Updated
2026-11-02
EUVDEUVD-2022-3948 No score

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Record
EUVD-2022-3948
Updated
2026-11-03
GitHub AdvisoriesGHSA-gg36-9346-9qx9 8.5

phpMyAdmin Remote Code Execution

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Record
GHSA-gg36-9346-9qx9
CVSS 3.1
8.5 HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSVGHSA-gg36-9346-9qx9 8.5

phpMyAdmin Remote Code Execution

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Record
GHSA-gg36-9346-9qx9
CVSS 3.1
8.5 HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV No score

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Record
CVE-2013-3239
Updated
2026-11-02
OSVDEBIAN-CVE-2013-3239 No score

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Record
DEBIAN-CVE-2013-3239
Updated
2026-11-02
OSVopenSUSE-SU-2024:10054-1 No score

phpMyAdmin-4.6.5.2-1.1 on GA media

These are all security issues fixed in the phpMyAdmin-4.6.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10054-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin/phpmyadmin
Packagist
3.5.0 up to 3.5.8.1
3.5.8.1
phpmyadmin
Debian:12
before 4:3.4.11.1-2
4:3.4.11.1-2
phpmyadmin
Debian:13
before 4:3.4.11.1-2
4:3.4.11.1-2
phpmyadmin
Debian:14
before 4:3.4.11.1-2
4:3.4.11.1-2
phpmyadmin
Debian:6.0
From an advisory covering 4 CVEs
before 4:3.3.7-8, plus listed versions
4:3.3.7-34:3.3.7-54:3.3.7-64:3.3.7-7
4:3.3.7-8
phpMyAdmin
openSUSE:Tumbleweed
From an advisory covering 124 CVEs
before 4.6.5.2-1.1
4.6.5.2-1.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBphpMyAdmin 3.5.8/4.0.0-RC2 - Multiple Vulnerabilities2013-04-25

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-3239 is a medium vulnerability (CVSS 4.6) in Phpmyadmin, published April 26, 2013. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 8.75%, the 95th percentile. Fixed in phpmyadmin/phpmyadmin 3.5.8.1.

References

Show 132 moreShow less
MoveEnter Open