Every CVE Search/ Get API key

CVE-2017-9066

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading...

8.6 HighFix available

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

3.67%Up 1.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.6

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.

Record
CVE-2017-9066
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-918
Updated
2026-11-02
CVE List No score

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.

Record
CVE-2017-9066
Updated
2026-11-02
EUVDEUVD-2017-18005 No score

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.

Record
EUVD-2017-18005
Updated
2026-11-03
GitHub AdvisoriesGHSA-hmqr-j9c3-8h75 8.6

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading...

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.

Record
GHSA-hmqr-j9c3-8h75
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Weakness
CWE-918
Updated
2026-11-02
OSV 8.6

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.

Record
CVE-2017-9066
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2017-9066 8.6

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.

Record
DEBIAN-CVE-2017-9066
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2017-9066 8.6

In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.

Record
UBUNTU-CVE-2017-9066
CVSS 3.0
8.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 4.7.5+dfsg-1
4.7.5+dfsg-1
wordpress
Debian:13
before 4.7.5+dfsg-1
4.7.5+dfsg-1
wordpress
Debian:14
before 4.7.5+dfsg-1
4.7.5+dfsg-1
wordpress
Debian:7
before 3.6.1+dfsg-1~deb7u16, plus listed versions
3.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-1
Show 23 moreShow less
3.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u73.6.1+dfsg-1~deb6u83.6.1+dfsg-1~deb6u93.6.1+dfsg-1~deb7u13.6.1+dfsg-1~deb7u103.6.1+dfsg-1~deb7u113.6.1+dfsg-1~deb7u123.6.1+dfsg-1~deb7u133.6.1+dfsg-1~deb7u143.6.1+dfsg-1~deb7u153.6.1+dfsg-1~deb7u23.6.1+dfsg-1~deb7u33.6.1+dfsg-1~deb7u43.6.1+dfsg-1~deb7u53.6.1+dfsg-1~deb7u63.6.1+dfsg-1~deb7u83.6.1+dfsg-1~deb7u9
3.6.1+dfsg-1~deb7u16
wordpress
Ubuntu:16.04:LTS
All versions, plus listed versions
4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9066 is a high vulnerability (CVSS 8.6) in Wordpress, published May 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.67%, the 89th percentile. Fixed in wordpress 4.7.5+dfsg-1.

References

Show 7 moreShow less
MoveEnter Open