Every CVE Search/ Get API key

CVE-2017-14313

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for...

6.1 MediumFix available

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.46%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Record
CVE-2017-14313
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Record
CVE-2017-14313
Updated
2026-11-02
EUVDEUVD-2017-5816 No score

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Record
EUVD-2017-5816
Updated
2026-11-03
GitHub AdvisoriesGHSA-h754-63f2-6hjc 6.1

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for...

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Record
GHSA-h754-63f2-6hjc
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Record
CVE-2017-14313
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2017-14313 6.1

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Record
DEBIAN-CVE-2017-14313
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2017-14313 6.1

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Record
UBUNTU-CVE-2017-14313
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress-shibboleth
Debian:12
before 1.8-1
1.8-1
wordpress-shibboleth
Debian:13
before 1.8-1
1.8-1
wordpress-shibboleth
Debian:7
before 1.4-2+deb7u1, plus listed versions
1.4-2
1.4-2+deb7u1
wordpress-shibboleth
Debian:8
before 1.4-2+deb8u1, plus listed versions
1.4-2
1.4-2+deb8u1
wordpress-shibboleth
Debian:9
before 1.4-2+deb9u1, plus listed versions
1.4-2
1.4-2+deb9u1
wordpress-shibboleth
Ubuntu:14.04:LTS
before 1.4-2+deb8u1build0.14.04.2, plus listed versions
1.4-2
1.4-2+deb8u1build0.14.04.2
wordpress-shibboleth
Ubuntu:16.04:LTS
before 1.4-2+deb8u1build0.16.04.2, plus listed versions
1.4-2
1.4-2+deb8u1build0.16.04.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-14313 is a medium vulnerability (CVSS 6.1) in Shibboleth Project Shibboleth, published September 12, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.46%, the 73rd percentile. Fixed in wordpress-shibboleth 1.8-1.

References

Show 4 moreShow less
MoveEnter Open