CVE-2017-15923
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial...
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
- Record
CVE-2017-15923- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
- Record
CVE-2017-15923- Updated
- 2026-11-02
EUVDEUVD-2017-7340 No score
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
- Record
EUVD-2017-7340- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gmxc-2h86-8gwf
7.5
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial...
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
- Record
GHSA-gmxc-2h86-8gwf- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
7.5
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
- Record
CVE-2017-15923- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-15923
7.5
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
- Record
DEBIAN-CVE-2017-15923- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-15923
7.5
Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
- Record
UBUNTU-CVE-2017-15923- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0419 No score
Updated konversation packages fix security vulnerability
Joseph Bisch discovered that Konversation could crash when parsing certain IRC color formatting codes (CVE-2017-15923).
- Record
MGASA-2017-0419- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10898-1 No score
konversation-21.08.1-1.2 on GA media
These are all security issues fixed in the konversation-21.08.1-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10898-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
konversationDebian:12 |
before 1.7.3-1 | 1.7.3-1 |
konversationDebian:13 |
before 1.7.3-1 | 1.7.3-1 |
konversationDebian:14 |
before 1.7.3-1 | 1.7.3-1 |
konversationDebian:7 |
before 1.4-1+deb7u2, plus listed versions 1.4-11.4-1+deb7u1 |
1.4-1+deb7u2 |
konversationDebian:8 |
before 1.5-2+deb8u1, plus listed versions 1.5-2 |
1.5-2+deb8u1 |
konversationDebian:9 |
before 1.6.2-2+deb9u1, plus listed versions 1.6.2-2 |
1.6.2-2+deb9u1 |
konversationMageia:5 |
before 1.5.1-1.1.mga5 | 1.5.1-1.1.mga5 |
konversationMageia:6 |
before 1.7.3-1.mga6 | 1.7.3-1.mga6 |
konversationUbuntu:14.04:LTS |
before 1.5-1ubuntu1.14.04.2, plus listed versions 1.5~rc1+git20130415-0ubuntu11.5-0ubuntu11.5-1ubuntu11.5-1ubuntu1.14.04.1 |
1.5-1ubuntu1.14.04.2 |
konversationUbuntu:16.04:LTS |
before 1.6-0ubuntu1.1, plus listed versions 1.6-0ubuntu1 |
1.6-0ubuntu1.1 |
konversationopenSUSE:Tumbleweed |
before 21.08.1-1.2 | 21.08.1-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-15923 is a high vulnerability (CVSS 7.5) in Konversation, published November 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.73%, the 86th percentile. Fixed in konversation 1.7.3-1.