CVE-2017-1000211
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory...
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
- Record
CVE-2017-1000211- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
- Record
CVE-2017-1000211- Updated
- 2026-11-02
EUVDEUVD-2017-1485 No score
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
- Record
EUVD-2017-1485- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6qv4-ghq2-3r52
5.3
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory...
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
- Record
GHSA-6qv4-ghq2-3r52- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
5.3
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
- Record
CVE-2017-1000211- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-1000211
5.3
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
- Record
DEBIAN-CVE-2017-1000211- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-1000211
5.3
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
- Record
UBUNTU-CVE-2017-1000211- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVMGASA-2017-0451 No score
Updated lynx package fixes security vulnerability
Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself. (CVE-2017-1000211)
- Record
MGASA-2017-0451- Updated
- 2026-11-02
OSVSUSE-SU-2017:3180-1 No score
Security update for lynx
This update for lynx fixes the following issues:
Security issue fixed:
- CVE-2017-1000211: Fix use after free in the HTMLparser that can resulting in memory disclosure (bsc#1068885).
- Record
SUSE-SU-2017:3180-1- Updated
- 2026-11-02
OSVUSN-4800-1 No score
lynx vulnerabilities
It was discovered that Lynx incorrectly handled certain URLs. A remote attacker could possibly use this issue to obtain sensitive information or other unspecified impact. This issue only affected Ubuntu 16.04 ESM. (CVE-2016-9179)
It was discovered that Lynx incorrectly handled certain HTML files. A remote attacker could possibly use this issue to obtain sensitive information. This issue only affected Ubuntu 16.04 ESM. (CVE-2017-1000211)
Thorsten Glaser discovered that Lynx mishandles the userinfo subcomponents of a URI. An attacker monitoring the network could discover cleartext credentials because they may appear in SNI data. (CVE-2021-38165)
- Record
USN-4800-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lynxDebian:12 |
before 2.8.9dev16-1 | 2.8.9dev16-1 |
lynxDebian:13 |
before 2.8.9dev16-1 | 2.8.9dev16-1 |
lynxDebian:14 |
before 2.8.9dev16-1 | 2.8.9dev16-1 |
lynx-curDebian:7 |
before 2.8.8dev.12-2+deb7u2, plus listed versions 2.8.8dev.12-22.8.8dev.12-2+deb7u1 |
2.8.8dev.12-2+deb7u2 |
lynxMageia:5 |
before 2.8.8-1.rel2.3.2.mga5 | 2.8.8-1.rel2.3.2.mga5 |
lynxMageia:6 |
before 2.8.8-1.rel2.6.1.mga6 | 2.8.8-1.rel2.6.1.mga6 |
lynxSUSE:Linux Enterprise Software Development Kit 11 SP4 |
before 2.8.6-146.3.1 | 2.8.6-146.3.1 |
lynxUbuntu:Pro:16.04:LTS |
before 2.8.9dev8-4ubuntu1+esm1, plus listed versions 2.8.9dev8-4ubuntu1 |
2.8.9dev8-4ubuntu1+esm1 |
lynxUbuntu:Pro:16.04:LTS From an advisory covering 3 CVEs |
before 2.8.9dev8-4ubuntu1+esm2, plus listed versions 2.8.9dev8-4ubuntu12.8.9dev8-4ubuntu1+esm1 |
2.8.9dev8-4ubuntu1+esm2 |
lynxUbuntu:Pro:18.04:LTS From an advisory covering 3 CVEs |
before 2.8.9dev16-3ubuntu0.1~esm1, plus listed versions 2.8.9dev16-12.8.9dev16-22.8.9dev16-3 |
2.8.9dev16-3ubuntu0.1~esm1 |
lynxUbuntu:Pro:20.04:LTS From an advisory covering 3 CVEs |
before 2.9.0dev.5-1ubuntu0.1~esm1, plus listed versions 2.9.0dev.4-12.9.0dev.5-1 |
2.9.0dev.5-1ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000211 is a medium vulnerability (CVSS 5.3) in Lynx Project Lynx, published November 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.73%, the 77th percentile. Fixed in lynx 2.8.9dev16-1.
References
lynx.invisible-island.net/current/CHANGES.html
securityfocus.com/bid/102180
github.com/ThomasDickey/lynx-snapshots/commit/280a61b300a1614f6037efc0902ff7ecf17146e9
lists.debian.org/debian-lts-announce/2017/11/msg00021.html
nvd.nist.gov/vuln/detail/CVE-2017-1000211
github.com/advisories/GHSA-6qv4-ghq2-3r52
Show 12 moreShow less
security-tracker.debian.org/tracker/CVE-2017-1000211
advisories.mageia.org/MGASA-2017-0451.html
bugs.mageia.org/show_bug.cgi?id=22132
lists.opensuse.org/opensuse-updates/2017-12/msg00007.html
suse.com/support/update/announcement/2017/suse-su-20173180-1
bugzilla.suse.com/1068885
suse.com/security/cve/CVE-2017-1000211
ubuntu.com/security/CVE-2017-1000211
cve.org/CVERecord?id=CVE-2017-1000211
ubuntu.com/security/notices/USN-4800-1
ubuntu.com/security/CVE-2016-9179
ubuntu.com/security/CVE-2021-38165