CVE-2017-17498
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial...
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
- Record
CVE-2017-17498- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
- Record
CVE-2017-17498- Updated
- 2026-11-02
EUVDEUVD-2017-8659 No score
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
- Record
EUVD-2017-8659- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-686m-6jxh-96vw
8.8
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial...
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
- Record
GHSA-686m-6jxh-96vw- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
8.8
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
- Record
CVE-2017-17498- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-17498
8.8
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
- Record
DEBIAN-CVE-2017-17498- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-17498
8.8
WritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
- Record
UBUNTU-CVE-2017-17498- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4248-1 No score
graphicsmagick vulnerabilities
It was discovered that GraphicsMagick incorrectly handled certain image files. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.
- Record
USN-4248-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
graphicsmagickDebian:12 |
before 1.3.27-1 | 1.3.27-1 |
graphicsmagickDebian:13 |
before 1.3.27-1 | 1.3.27-1 |
graphicsmagickDebian:14 |
before 1.3.27-1 | 1.3.27-1 |
graphicsmagickDebian:7 From an advisory covering 8 CVEs |
before 1.3.16-1.1+deb7u16, plus listed versions 1.3.16-1.11.3.16-1.1+deb7u11.3.16-1.1+deb7u101.3.16-1.1+deb7u111.3.16-1.1+deb7u12 Show 11 moreShow less1.3.16-1.1+deb7u131.3.16-1.1+deb7u141.3.16-1.1+deb7u151.3.16-1.1+deb7u21.3.16-1.1+deb7u31.3.16-1.1+deb7u41.3.16-1.1+deb7u51.3.16-1.1+deb7u61.3.16-1.1+deb7u71.3.16-1.1+deb7u81.3.16-1.1+deb7u9 |
1.3.16-1.1+deb7u16 |
graphicsmagickDebian:8 From an advisory covering 27 CVEs |
before 1.3.20-3+deb8u3, plus listed versions 1.3.20-3+deb8u11.3.20-3+deb8u2 |
1.3.20-3+deb8u3 |
graphicsmagickDebian:9 From an advisory covering 56 CVEs |
before 1.3.30+hg15796-1~deb9u1, plus listed versions 1.3.25-81.3.26-11.3.26-101.3.26-111.3.26-12 Show 24 moreShow less1.3.26-131.3.26-141.3.26-151.3.26-161.3.26-171.3.26-181.3.26-191.3.26-21.3.26-31.3.26-41.3.26-51.3.26-61.3.26-71.3.26-81.3.26-91.3.27-11.3.27-21.3.27-31.3.27-41.3.28-11.3.28-21.3.29+hg15665-11.3.29-11.3.30-1 |
1.3.30+hg15796-1~deb9u1 |
graphicsmagickUbuntu:Pro:14.04:LTS |
before 1.3.18-1ubuntu3.1+esm5, plus listed versions 1.3.16-1.1ubuntu21.3.16-1.1ubuntu31.3.18-1ubuntu31.3.18-1ubuntu3.11.3.18-1ubuntu3.1+esm11.3.18-1ubuntu3.1+esm21.3.18-1ubuntu3.1+esm31.3.18-1ubuntu3.1+esm4 |
1.3.18-1ubuntu3.1+esm5 |
graphicsmagickUbuntu:16.04:LTS |
before 1.3.23-1ubuntu0.5, plus listed versions 1.3.21-31.3.23-11.3.23-1build11.3.23-1ubuntu0.11.3.23-1ubuntu0.21.3.23-1ubuntu0.31.3.23-1ubuntu0.4 |
1.3.23-1ubuntu0.5 |
graphicsmagickUbuntu:16.04:LTS From an advisory covering 10 CVEs |
before 1.3.23-1ubuntu0.5, plus listed versions 1.3.21-31.3.23-11.3.23-1build11.3.23-1ubuntu0.11.3.23-1ubuntu0.21.3.23-1ubuntu0.31.3.23-1ubuntu0.4 |
1.3.23-1ubuntu0.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-17498 is a high vulnerability (CVSS 8.8) in Graphicsmagick, published December 11, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.90%, the 87th percentile. Fixed in graphicsmagick 1.3.27-1.
References
securityfocus.com/bid/102158
debian.org/security/2018/dsa-4321
lists.debian.org/debian-lts-announce/2018/06/msg00009.html
hg.code.sf.net/p/graphicsmagick/code/rev/f1c418ef0260
lists.debian.org/debian-lts-announce/2018/01/msg00005.html
sourceforge.net/p/graphicsmagick/bugs/525
Show 20 moreShow less
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PF62B5PJA2JDUOCKJGUQO3SPL74BEYSV
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WHIKB4TP6KBJWT2UIPWL5MWMG5QXKGEJ
usn.ubuntu.com/4248-1
nvd.nist.gov/vuln/detail/CVE-2017-17498
lists.fedoraproject.org/archives/list/[email protected]/message/PF62B5PJA2JDUOCKJGUQO3SPL74BEYSV
lists.fedoraproject.org/archives/list/[email protected]/message/WHIKB4TP6KBJWT2UIPWL5MWMG5QXKGEJ
github.com/advisories/GHSA-686m-6jxh-96vw
security-tracker.debian.org/tracker/CVE-2017-17498
ubuntu.com/security/CVE-2017-17498
ubuntu.com/security/notices/USN-4248-1
cve.org/CVERecord?id=CVE-2017-17498
ubuntu.com/security/CVE-2017-16545
ubuntu.com/security/CVE-2017-16547
ubuntu.com/security/CVE-2017-16669
ubuntu.com/security/CVE-2017-17500
ubuntu.com/security/CVE-2017-17501
ubuntu.com/security/CVE-2017-17502
ubuntu.com/security/CVE-2017-17503
ubuntu.com/security/CVE-2017-17782
ubuntu.com/security/CVE-2017-17783