CVE-2016-10510
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows...
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows remote attackers to inject arbitrary web script or HTML by bypassing the strip_image_tags protection mechanism in system/classes/Kohana/Security.php.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows remote attackers to inject arbitrary web script or HTML by bypassing the strip_image_tags protection mechanism in system/classes/Kohana/Security.php.
- Record
CVE-2016-10510- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows remote attackers to inject arbitrary web script or HTML by bypassing the strip_image_tags protection mechanism in system/classes/Kohana/Security.php.
- Record
CVE-2016-10510- Updated
- 2026-11-02
EUVDEUVD-2016-1692 No score
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows remote attackers to inject arbitrary web script or HTML by bypassing the strip_image_tags protection mechanism in system/classes/Kohana/Security.php.
- Record
EUVD-2016-1692- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jpf9-3cq3-2phg
6.1
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows...
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows remote attackers to inject arbitrary web script or HTML by bypassing the strip_image_tags protection mechanism in system/classes/Kohana/Security.php.
- Record
GHSA-jpf9-3cq3-2phg- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows remote attackers to inject arbitrary web script or HTML by bypassing the strip_image_tags protection mechanism in system/classes/Kohana/Security.php.
- Record
CVE-2016-10510- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10510
6.1
Cross-site scripting (XSS) vulnerability in the Security component of Kohana before 3.3.6 allows remote attackers to inject arbitrary web script or HTML by bypassing the strip_image_tags protection mechanism in system/classes/Kohana/Security.php.
- Record
UBUNTU-CVE-2016-10510- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libkohana2-phpDebian:7 |
before 2.3.4-2+deb7u1, plus listed versions 2.3.4-2 |
2.3.4-2+deb7u1 |
libkohana2-phpUbuntu:14.04:LTS |
before 2.3.4-2+deb7u1build0.14.04.1, plus listed versions 2.3.4-2 |
2.3.4-2+deb7u1build0.14.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10510 is a medium vulnerability (CVSS 6.1) in Kohanaframework Kohana, published August 31, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.66%, the 76th percentile. Fixed in libkohana2-php 2.3.4-2+deb7u1.
References
lists.debian.org/debian-lts-announce/2018/01/msg00015.html
github.com/kohana/kohana/releases/tag/v3.3.6
github.com/kohana/kohana/issues/107
checkmarx.com/advisories/cross-site-scripting-xss-vulnerability-in-kohana
advisory.checkmarx.net/advisory/CX-2016-4451
nvd.nist.gov/vuln/detail/CVE-2016-10510
github.com/advisories/GHSA-jpf9-3cq3-2phg
ubuntu.com/security/CVE-2016-10510
cve.org/CVERecord?id=CVE-2016-10510