CVE-2017-18123
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode...
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.6
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
- Record
CVE-2017-18123- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
- Record
CVE-2017-18123- Updated
- 2026-11-02
EUVDEUVD-2017-9258 No score
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
- Record
EUVD-2017-9258- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9v2g-x5vw-rfgc
8.6
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode...
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
- Record
GHSA-9v2g-x5vw-rfgc- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
8.6
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
- Record
CVE-2017-18123- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-18123
8.6
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
- Record
DEBIAN-CVE-2017-18123- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-18123
8.6
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
- Record
UBUNTU-CVE-2017-18123- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dokuwikiDebian:12 |
before 0.0.20160626.a-2.1 | 0.0.20160626.a-2.1 |
dokuwikiDebian:13 |
before 0.0.20160626.a-2.1 | 0.0.20160626.a-2.1 |
dokuwikiDebian:14 |
before 0.0.20160626.a-2.1 | 0.0.20160626.a-2.1 |
dokuwikiDebian:7 |
before 0.0.20120125b-2+deb7u2, plus listed versions 0.0.20120125b-20.0.20120125b-2+deb7u1 |
0.0.20120125b-2+deb7u2 |
dokuwikiDebian:8 |
before 0.0.20140505.a+dfsg-4+deb8u1, plus listed versions 0.0.20140505.a+dfsg-4 |
0.0.20140505.a+dfsg-4+deb8u1 |
dokuwikiUbuntu:16.04:LTS |
All versions, plus listed versions 0.0.20140929.d-10.0.20140929.d-1ubuntu1 |
None known |
dokuwikiUbuntu:18.04:LTS |
All versions, plus listed versions 0.0.20160626.a-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-18123 is a high vulnerability (CVSS 8.6) in Dokuwiki, published February 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.60%, the 85th percentile. Fixed in dokuwiki 0.0.20160626.a-2.1.