CVE-2018-5735
Backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858; Affects Debian versions 9.9.5.dfsg-9+deb8u15; 9.9.5.dfsg-9+deb8u18; 9.10.3.dfsg.P4-12.3+deb9u5; 9.11.5.P4+dfsg-5.1 No ISC releases are affected. Other packages from other distributions who did similar backports for the fix for 2017-3137 may also be affected.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858; Affects Debian versions 9.9.5.dfsg-9+deb8u15; 9.9.5.dfsg-9+deb8u18; 9.10.3.dfsg.P4-12.3+deb9u5; 9.11.5.P4+dfsg-5.1 No ISC releases are affected. Other packages from other distributions who did similar backports for the fix for 2017-3137 may also be affected.
- Record
CVE-2018-5735- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
EUVDEUVD-2018-17504
7.5
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858; Affects Debian versions 9.9.5.dfsg-9+deb8u15; 9.9.5.dfsg-9+deb8u18; 9.10.3.dfsg.P4-12.3+deb9u5; 9.11.5.P4+dfsg-5.1 No ISC releases are affected. Other packages from other distributions who did similar backports for the fix for 2017-3137 may also be affected.
- Record
EUVD-2018-17504- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qp2w-qqh3-4x36
7.5
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858;...
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858; Affects Debian versions 9.9.5.dfsg-9+deb8u15; 9.9.5.dfsg-9+deb8u18; 9.10.3.dfsg.P4-12.3+deb9u5; 9.11.5.P4+dfsg-5.1 No ISC releases are affected. Other packages from other distributions who did similar backports for the fix for 2017-3137 may also be affected.
- Record
GHSA-qp2w-qqh3-4x36- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-617
- Updated
- 2026-11-02
NVD
7.5
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858; Affects Debian versions 9.9.5.dfsg-9+deb8u15; 9.9.5.dfsg-9+deb8u18; 9.10.3.dfsg.P4-12.3+deb9u5; 9.11.5.P4+dfsg-5.1 No ISC releases are affected. Other packages from other distributions who did similar backports for the fix for 2017-3137 may also be affected.
- Record
CVE-2018-5735- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-617
- Updated
- 2026-11-02
OSV
7.5
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858; Affects Debian versions 9.9.5.dfsg-9+deb8u15; 9.9.5.dfsg-9+deb8u18; 9.10.3.dfsg.P4-12.3+deb9u5; 9.11.5.P4+dfsg-5.1 No ISC releases are affected. Other packages from other distributions who did similar backports for the fix for 2017-3137 may also be affected.
- Record
CVE-2018-5735- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-5735
7.5
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858; Affects Debian versions 9.9.5.dfsg-9+deb8u15; 9.9.5.dfsg-9+deb8u18; 9.10.3.dfsg.P4-12.3+deb9u5; 9.11.5.P4+dfsg-5.1 No ISC releases are affected. Other packages from other distributions who did similar backports for the fix for 2017-3137 may also be affected.
- Record
DEBIAN-CVE-2018-5735- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-5735
7.5
The Debian backport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:1858; Affects Debian versions 9.9.5.dfsg-9+deb8u15; 9.9.5.dfsg-9+deb8u18; 9.10.3.dfsg.P4-12.3+deb9u5; 9.11.5.P4+dfsg-5.1 No ISC releases are affected. Other packages from other distributions who did similar backports for the fix for 2017-3137 may also be affected.
- Record
UBUNTU-CVE-2018-5735- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
bind9Debian:12 |
before 1:9.9.3.dfsg.P2-1 | 1:9.9.3.dfsg.P2-1 |
bind9Debian:13 |
before 1:9.9.3.dfsg.P2-1 | 1:9.9.3.dfsg.P2-1 |
bind9Debian:14 |
before 1:9.9.3.dfsg.P2-1 | 1:9.9.3.dfsg.P2-1 |
bind9Debian:7 |
before 1:9.8.4.dfsg.P1-6+nmu2+deb7u20, plus listed versions 1:9.8.4.dfsg.P1-6+nmu21:9.8.4.dfsg.P1-6+nmu2+deb7u11:9.8.4.dfsg.P1-6+nmu2+deb7u101:9.8.4.dfsg.P1-6+nmu2+deb7u111:9.8.4.dfsg.P1-6+nmu2+deb7u12 Show 17 moreShow less1:9.8.4.dfsg.P1-6+nmu2+deb7u131:9.8.4.dfsg.P1-6+nmu2+deb7u141:9.8.4.dfsg.P1-6+nmu2+deb7u151:9.8.4.dfsg.P1-6+nmu2+deb7u161:9.8.4.dfsg.P1-6+nmu2+deb7u171:9.8.4.dfsg.P1-6+nmu2+deb7u181:9.8.4.dfsg.P1-6+nmu2+deb7u191:9.8.4.dfsg.P1-6+nmu2+deb7u1~bpo60+11:9.8.4.dfsg.P1-6+nmu2+deb7u21:9.8.4.dfsg.P1-6+nmu2+deb7u2~bpo60+11:9.8.4.dfsg.P1-6+nmu2+deb7u31:9.8.4.dfsg.P1-6+nmu2+deb7u41:9.8.4.dfsg.P1-6+nmu2+deb7u51:9.8.4.dfsg.P1-6+nmu2+deb7u61:9.8.4.dfsg.P1-6+nmu2+deb7u71:9.8.4.dfsg.P1-6+nmu2+deb7u81:9.8.4.dfsg.P1-6+nmu2+deb7u9 |
1:9.8.4.dfsg.P1-6+nmu2+deb7u20 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-5735 is a high vulnerability (CVSS 7.5) in Debian Bind9, published February 16, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.39%, the 72nd percentile. Fixed in bind9 1:9.9.3.dfsg.P2-1.