CVE-2014-8628
Memory leak in PolarSSL before 1.2.12 and 1.3.x before 1.3.9 allows remote attackers to cause a...
Memory leak in PolarSSL before 1.2.12 and 1.3.x before 1.3.9 allows remote attackers to cause a denial of service (memory consumption) via a large number of crafted X.509 certificates. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2014-9744 for the ClientHello message issue.
Exploit likelihood
What each source reports
NVD Score used
7.8
Memory leak in PolarSSL before 1.2.12 and 1.3.x before 1.3.9 allows remote attackers to cause a denial of service (memory consumption) via a large number of crafted X.509 certificates. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2014-9744 for the ClientHello message issue.
- Record
CVE-2014-8628- CVSS 2.0
- 7.8 High
AV:N/AC:L/Au:N/C:N/I:N/A:C - Weakness
- CWE-399
- Updated
- 2026-11-02
CVE List No score
Memory leak in PolarSSL before 1.2.12 and 1.3.x before 1.3.9 allows remote attackers to cause a denial of service (memory consumption) via a large number of crafted X.509 certificates. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2014-9744 for the ClientHello message issue.
- Record
CVE-2014-8628- Updated
- 2026-11-02
EUVDEUVD-2014-8465 No score
Memory leak in PolarSSL before 1.2.12 and 1.3.x before 1.3.9 allows remote attackers to cause a denial of service (memory consumption) via a large number of crafted X.509 certificates. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2014-9744 for the ClientHello message issue.
- Record
EUVD-2014-8465- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pq2v-pvrw-m6q9 No score
Memory leak in PolarSSL before 1.2.12 and 1.3.x before 1.3.9 allows remote attackers to cause a...
Memory leak in PolarSSL before 1.2.12 and 1.3.x before 1.3.9 allows remote attackers to cause a denial of service (memory consumption) via a large number of crafted X.509 certificates. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2014-9744 for the ClientHello message issue.
- Record
GHSA-pq2v-pvrw-m6q9- Updated
- 2026-11-02
OSVMGASA-2014-0481 No score
Updated polarssl package fix security vulnerabilities
A regression in PolarSSL 1.3.8 resulted in servers negotiating a weaker signature algorithm than available. This has been fixed in PolarSSL 1.3.9 (CVE-2014-8627).
Two remotely-triggerable memory leaks were found by the Codenomicon Defensics tool and fixed in PolarSSL 1.3.9 (CVE-2014-8628).
- Record
MGASA-2014-0481- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10088-1 No score
libmbedcrypto0-2.4.0-1.2 on GA media
These are all security issues fixed in the libmbedcrypto0-2.4.0-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10088-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:12903-1 No score
libmbedcrypto7-2.28.3-1.1 on GA media
These are all security issues fixed in the libmbedcrypto7-2.28.3-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:12903-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:11119-1 No score
libeverest-3.6.6-1.1 on GA media
These are all security issues fixed in the libeverest-3.6.6-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:11119-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
polarsslDebian:6.0 |
before 1.2.9-1~deb6u3, plus listed versions 0.12.1-10.12.1-1squeeze10.14.3-11.0.0-11.0.0-2 Show 19 moreShow less1.0.0-2+s390x1.0.0-31.1.0-11.1.1-11.1.2-11.1.3-11.1.4-11.1.4-21.2.0-11.2.2-11.2.3-11.2.4-11.2.5-11.2.6-11.2.7-11.2.8-11.2.8-21.2.9-1~deb6u11.2.9-1~deb6u2 |
1.2.9-1~deb6u3 |
polarsslDebian:7 |
before 1.2.9-1~deb7u4, plus listed versions 1.1.4-21.2.0-11.2.2-11.2.3-11.2.4-1 Show 13 moreShow less1.2.5-11.2.6-11.2.7-11.2.8-11.2.8-21.2.9-1~deb6u11.2.9-1~deb6u21.2.9-1~deb6u31.2.9-1~deb6u41.2.9-1~deb6u51.2.9-1~deb7u11.2.9-1~deb7u21.2.9-1~deb7u3 |
1.2.9-1~deb7u4 |
polarsslMageia:3 |
before 1.3.9-1.mga3 | 1.3.9-1.mga3 |
polarsslMageia:4 |
before 1.3.9-1.mga4 | 1.3.9-1.mga4 |
mbedtlsopenSUSE:Tumbleweed |
before 2.4.0-1.2 | 2.4.0-1.2 |
mbedtls-2openSUSE:Tumbleweed |
before 2.28.3-1.1 | 2.28.3-1.1 |
mbedtls-3openSUSE:Tumbleweed |
before 3.6.6-1.1 | 3.6.6-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-8628 is a high vulnerability (CVSS 7.8) in Polarssl, published November 22, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.72%, the 77th percentile. Fixed in polarssl 1.2.9-1~deb6u3.
References
lists.opensuse.org/opensuse-updates/2014-11/msg00079.html
debian.org/security/2014/dsa-3116
polarssl.org/tech-updates/releases/polarssl-1.3.9-released
polarssl.org/tech-updates/releases/polarssl-1.2.12-released
nvd.nist.gov/vuln/detail/CVE-2014-8628
github.com/advisories/GHSA-pq2v-pvrw-m6q9
Show 17 moreShow less
advisories.mageia.org/MGASA-2014-0481.html
bugs.mageia.org/show_bug.cgi?id=14472
openwall.com/lists/oss-security/2014/11/06/4
suse.com/security/cve/CVE-2014-8627
suse.com/security/cve/CVE-2014-8628
suse.com/security/cve/CVE-2015-1182
suse.com/security/cve/CVE-2015-5291
suse.com/security/cve/CVE-2015-7575
suse.com/security/cve/CVE-2017-14032
suse.com/security/cve/CVE-2017-2784
suse.com/security/cve/CVE-2018-0487
suse.com/security/cve/CVE-2018-0488
suse.com/security/cve/CVE-2018-19608
suse.com/security/cve/CVE-2021-24119
suse.com/security/cve/CVE-2021-45450
suse.com/security/cve/CVE-2022-35409
suse.com/security/cve/CVE-2022-46393