Every CVE Search/ Get API key

CVE-2017-11509

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7...

8.8 HighFix available

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

6.15%Up 4.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

Record
CVE-2017-11509
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

Record
CVE-2017-11509
Updated
2026-11-02
EUVDEUVD-2017-3126 No score

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

Record
EUVD-2017-3126
Updated
2026-11-03
GitHub AdvisoriesGHSA-6pp2-h2x8-7cp5 8.8

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7...

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

Record
GHSA-6pp2-h2x8-7cp5
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSV 8.8

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

Record
CVE-2017-11509
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-11509 8.8

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

Record
DEBIAN-CVE-2017-11509
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-11509 8.8

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

Record
UBUNTU-CVE-2017-11509
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVSUSE-SU-2025:03095-1 No score

Security update for firebird

This update for firebird fixes the following issues:

  • CVE-2017-11509: authenticated remote code execution via the definition external functions that don't match the original definition of the entry point (bsc#1087421).
Record
SUSE-SU-2025:03095-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
firebird3.0
Debian:12
before 3.0.3.32900.ds4-3
3.0.3.32900.ds4-3
firebird3.0
Debian:13
before 3.0.3.32900.ds4-3
3.0.3.32900.ds4-3
firebird3.0
Debian:14
before 3.0.3.32900.ds4-3
3.0.3.32900.ds4-3
firebird2.5
Debian:7
before 2.5.2.26540.ds4-1~deb7u4, plus listed versions
2.5.2.26540.ds4-1~deb7u12.5.2.26540.ds4-1~deb7u22.5.2.26540.ds4-1~deb7u32.5.2~svn+54698.ds4-3
2.5.2.26540.ds4-1~deb7u4
firebird2.5
Debian:8
before 2.5.3.26778.ds4-5+deb8u2, plus listed versions
2.5.3.26778.ds4-52.5.3.26778.ds4-5+deb8u1
2.5.3.26778.ds4-5+deb8u2
firebird3.0
Debian:9
before 3.0.1.32609.ds4-14+deb9u1, plus listed versions
3.0.1.32609.ds4-14
3.0.1.32609.ds4-14+deb9u1
firebird
SUSE:Linux Enterprise Module for Package Hub 15 SP6
before 3.0.4.33054-150200.3.6.1
3.0.4.33054-150200.3.6.1
firebird
SUSE:Linux Enterprise Module for Package Hub 15 SP7
before 3.0.4.33054-150200.3.6.1
3.0.4.33054-150200.3.6.1
firebird
openSUSE:Leap 15.6
before 3.0.4.33054-150200.3.6.1
3.0.4.33054-150200.3.6.1
firebird2.5
Ubuntu:14.04:LTS
All versions, plus listed versions
2.5.2.26540.ds4-32.5.2.26540.ds4-72.5.2.26540.ds4-82.5.2.26540.ds4-8ubuntu12.5.2.26540.ds4-8ubuntu22.5.2.26540.ds4-9ubuntu12.5.2.26540.ds4-9ubuntu1.1
None known
firebird2.5
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.5.4.26856.ds4-1build12.5.4.26856.ds4-1ubuntu0.1~esm1
None known
firebird3.0
Ubuntu:18.04:LTS
All versions, plus listed versions
3.0.2.32703.ds4-93.0.2.32703.ds4-11ubuntu13.0.2.32703.ds4-11ubuntu2
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-11509 is a high vulnerability (CVSS 8.8) in Firebird Foundation Sql Server, published March 28, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.15%, the 93rd percentile. Fixed in firebird3.0 3.0.3.32900.ds4-3.

References

Show 6 moreShow less
MoveEnter Open