Every CVE Search/ Get API key

CVE-2015-8915

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid...

5.5 MediumFix available

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.82%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

Record
CVE-2015-8915
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

Record
CVE-2015-8915
Updated
2026-11-02
EUVDEUVD-2015-8771 No score

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

Record
EUVD-2015-8771
Updated
2026-11-03
GitHub AdvisoriesGHSA-c9hw-3xr3-f2qr 5.5

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid...

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

Record
GHSA-c9hw-3xr3-f2qr
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 5.5

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

Record
CVE-2015-8915
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8915 5.5

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

Record
DEBIAN-CVE-2015-8915
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2015-8915 5.5

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

Record
UBUNTU-CVE-2015-8915
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libarchive
Debian:12
before 3.2.0-2
3.2.0-2
libarchive
Debian:13
before 3.2.0-2
3.2.0-2
libarchive
Debian:14
before 3.2.0-2
3.2.0-2
libarchive
Debian:8
before 3.1.2-11+deb8u4, plus listed versions
3.1.2-113.1.2-11+deb8u13.1.2-11+deb8u23.1.2-11+deb8u33.1.2-11+deb8u3~bpo70+1
3.1.2-11+deb8u4
libarchive
Debian:7
before 3.0.4-3+wheezy3, plus listed versions
3.0.4-3+nmu13.0.4-3+wheezy13.0.4-3+wheezy2
3.0.4-3+wheezy3
libarchive
Ubuntu:14.04:LTS
before 3.1.2-7ubuntu2.2, plus listed versions
3.1.2-5ubuntu13.1.2-7ubuntu13.1.2-7ubuntu23.1.2-7ubuntu2.1
3.1.2-7ubuntu2.2
libarchive
Ubuntu:16.04:LTS
before 3.1.2-11ubuntu0.16.04.1, plus listed versions
3.1.2-11build1
3.1.2-11ubuntu0.16.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8915 is a medium vulnerability (CVSS 5.5) in Libarchive, published September 10, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.82%, the 78th percentile. Fixed in libarchive 3.2.0-2.

References

Show 7 moreShow less
MoveEnter Open