CVE-2018-1056
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02...
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
3.3
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
- Record
CVE-2018-1056- CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - Weakness
- CWE-122
- Updated
- 2026-11-02
EUVDEUVD-2018-11709
3.3
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
- Record
EUVD-2018-11709- CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-557x-wcm4-fhw8
7.8
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02...
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
- Record
GHSA-557x-wcm4-fhw8- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
NVD
7.8
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
- Record
CVE-2018-1056- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-122, CWE-125
- Updated
- 2026-11-02
OSV
7.8
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
- Record
CVE-2018-1056- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-1056
7.8
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
- Record
DEBIAN-CVE-2018-1056- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-1056
7.8
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
- Record
UBUNTU-CVE-2018-1056- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0141 No score
Updated advancecomp packages fix security vulnerability
Joonun Jang discovered a vulnerability in AdvanceCOMP that could be used to crash or run programs if it opened a specially crafted ZIP file.
- Record
MGASA-2018-0141- Updated
- 2026-11-02
OSVUSN-3570-1 No score
advancecomp vulnerability
Joonun Jang discovered that AdvanceCOMP incorrectly handled certain malformed zip files. If a user or automated system were tricked into processing a specially crafted zip file, a remote attacker could cause AdvanceCOMP to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-3570-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
advancecompDebian:12 |
before 2.1-1 | 2.1-1 |
advancecompDebian:13 |
before 2.1-1 | 2.1-1 |
advancecompDebian:14 |
before 2.1-1 | 2.1-1 |
advancecompDebian:7 |
before 1.15-1+deb7u1, plus listed versions 1.15-1 |
1.15-1+deb7u1 |
advancecompDebian:8 |
before 1.19-1+deb8u1, plus listed versions 1.19-1 |
1.19-1+deb8u1 |
advancecompDebian:9 |
before 1.20-1+deb9u1, plus listed versions 1.20-1 |
1.20-1+deb9u1 |
advancecompMageia:6 |
before 1.20-3.1.mga6 | 1.20-3.1.mga6 |
advancecompUbuntu:14.04:LTS |
before 1.18-1ubuntu0.1, plus listed versions 1.17-11.18-1 |
1.18-1ubuntu0.1 |
advancecompUbuntu:16.04:LTS |
before 1.20-1ubuntu0.1, plus listed versions 1.19-11.20-1 |
1.20-1ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1056 is a low vulnerability (CVSS 3.3) in Advancemame Advancecomp, published February 8, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in advancecomp 2.1-1.
References
lists.debian.org/debian-lts-announce/2019/03/msg00004.html
bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1056
bugs.debian.org/cgi-bin/bugreport.cgi?bug=889270
usn.ubuntu.com/3570-1
lists.debian.org/debian-lts-announce/2018/02/msg00016.html
sourceforge.net/p/advancemame/bugs/259
Show 9 moreShow less
lists.debian.org/debian-lts-announce/2021/12/msg00034.html
nvd.nist.gov/vuln/detail/CVE-2018-1056
github.com/advisories/GHSA-557x-wcm4-fhw8
security-tracker.debian.org/tracker/CVE-2018-1056
advisories.mageia.org/MGASA-2018-0141.html
bugs.mageia.org/show_bug.cgi?id=22612
ubuntu.com/security/CVE-2018-1056
ubuntu.com/security/notices/USN-3570-1
cve.org/CVERecord?id=CVE-2018-1056