CVE-2019-11627
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling...
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
- Record
CVE-2019-11627- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
- Record
CVE-2019-11627- Updated
- 2026-11-02
EUVDEUVD-2019-3297 No score
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
- Record
EUVD-2019-3297- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rc9j-5pgx-7w89
9.8
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling...
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
- Record
GHSA-rc9j-5pgx-7w89- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
9.8
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
- Record
CVE-2019-11627- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-11627
9.8
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
- Record
DEBIAN-CVE-2019-11627- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2019-11627
9.8
gpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
- Record
UBUNTU-CVE-2019-11627- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2019-0386 No score
Updated signing-party packages fix security vulnerability
Updated signing-party package fixes security vulnerability:
The gpg-key2ps tool in signing-party contained an unsafe shell call enabling shell injection via a User ID (CVE-2019-11627).
- Record
MGASA-2019-0386- Updated
- 2026-11-02
OSVopenSUSE-SU-2019:1388-1 No score
Security update for signing-party
This update for signing-party fixes the following issues:
- CVE-2019-11627: The gpg-key2ps tool in signing-party contained an unsafe shell call enabling shell injection via a User ID.
- Record
openSUSE-SU-2019:1388-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11383-1 No score
signing-party-2.11-1.3 on GA media
These are all security issues fixed in the signing-party-2.11-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11383-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
signing-partyDebian:12 |
before 2.10-1 | 2.10-1 |
signing-partyDebian:13 |
before 2.10-1 | 2.10-1 |
signing-partyDebian:14 |
before 2.10-1 | 2.10-1 |
signing-partyDebian:8 |
before 1.1.10-3+deb8u1, plus listed versions 1.1.10-3 |
1.1.10-3+deb8u1 |
signing-partyMageia:7 |
before 2.10-1.mga7 | 2.10-1.mga7 |
signing-partyUbuntu:16.04:LTS |
All versions, plus listed versions 2.1-12.2-1 |
None known |
signing-partyUbuntu:18.04:LTS |
All versions, plus listed versions 2.6-12.7-1 |
None known |
signing-partyopenSUSE:Leap 15.0 |
before 2.7-lp150.5.1 | 2.7-lp150.5.1 |
signing-partyopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 2.11-1.3 | 2.11-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-11627 is a critical vulnerability (CVSS 9.8) in Signing-party Project Signing-party, published April 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.74%, the 86th percentile. Fixed in signing-party 2.10-1.
References
bugs.debian.org/928256
lists.debian.org/debian-lts-announce/2019/05/msg00001.html
lists.opensuse.org/opensuse-security-announce/2019-05/msg00029.html
nvd.nist.gov/vuln/detail/CVE-2019-11627
github.com/advisories/GHSA-rc9j-5pgx-7w89
security-tracker.debian.org/tracker/CVE-2019-11627
Show 9 moreShow less
advisories.mageia.org/MGASA-2019-0386.html
bugs.mageia.org/show_bug.cgi?id=25742
lists.opensuse.org/opensuse-updates/2019-05/msg00085.html
ubuntu.com/security/CVE-2019-11627
cve.org/CVERecord?id=CVE-2019-11627
lists.opensuse.org/archives/list/[email protected]/thread/P4LBOOSAOJK2GYZYJAKYSNCQP7DX2WIN
bugzilla.suse.com/1134040
suse.com/security/cve/CVE-2019-11627
suse.com/security/cve/CVE-2018-15599