Every CVE Search/ Get API key

CVE-2019-12816

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate...

8.8 HighFix available

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.05%Down 1.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Record
CVE-2019-12816
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Record
CVE-2019-12816
Updated
2026-11-02
EUVDEUVD-2019-4397 No score

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Record
EUVD-2019-4397
Updated
2026-11-03
GitHub AdvisoriesGHSA-fvh5-rgvr-c634 No score

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate...

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Record
GHSA-fvh5-rgvr-c634
Updated
2026-11-02
OSVALPINE-CVE-2019-12816 8.8

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Record
ALPINE-CVE-2019-12816
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Record
CVE-2019-12816
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 7 moreShow less
OSVDEBIAN-CVE-2019-12816 8.8

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Record
DEBIAN-CVE-2019-12816
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-12816 8.8

Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

Record
UBUNTU-CVE-2019-12816
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0262 No score

Updated znc packages fix security vulnerabilities

Jeriko One discovered two vulnerabilities in the ZNC IRC bouncer which could result in privilege escalation or denial of service (CVE-2018-14055, CVE-2018-14056).

Two vulnerabilities were discovered in the ZNC IRC bouncer which could result in remote code execution (CVE-2019-12816) or denial of service via invalid encoding (CVE-2019-9917).

Record
MGASA-2019-0262
Updated
2026-11-02
OSVopenSUSE-SU-2019:1775-1 No score

Security update for znc

This update for znc to version 1.7.4 fixes the following issues:

Security issues fixed:

  • CVE-2019-12816: Fixed a remote code execution in Modules.cpp (boo#1138572).
  • CVE-2019-9917: Fixed a denial of service on invalid encoding (boo#1130360).
Record
openSUSE-SU-2019:1775-1
Updated
2026-11-02
OSVopenSUSE-SU-2019:1859-1 No score

Security update for znc

This update for znc to version 1.7.4 fixes the following issues:

Security issues fixed:

  • CVE-2019-12816: Fixed a remote code execution in Modules.cpp (boo#1138572).
  • CVE-2019-9917: Fixed a denial of service on invalid encoding (boo#1130360).

This update was imported from the openSUSE:Leap:15.0:Update update project.

Record
openSUSE-SU-2019:1859-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11542-1 No score

znc-1.8.2-1.11 on GA media

These are all security issues fixed in the znc-1.8.2-1.11 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11542-1
Updated
2026-11-02
OSVUSN-4044-1 No score

znc vulnerability

Fix vulnerability where an authenticated non-admin users could load a module with a crafted name, then escalate privileges and run arbitrary code.

Record
USN-4044-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
znc
Alpine:v3.10
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.11
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.12
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.13
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.14
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.15
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.16
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.17
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.18
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.19
before 1.7.4-r0
1.7.4-r0
Show 23 moreShow less
Affected packages
PackageAffectedFixed
znc
Alpine:v3.20
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.21
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.22
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.23
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.24
before 1.7.4-r0
1.7.4-r0
znc
Alpine:v3.7
before 1.7.1-r1
1.7.1-r1
znc
Alpine:v3.8
before 1.7.1-r1
1.7.1-r1
znc
Alpine:v3.9
before 1.7.1-r4
1.7.1-r4
znc
Debian:12
before 1.7.2-3
1.7.2-3
znc
Debian:13
before 1.7.2-3
1.7.2-3
znc
Debian:14
before 1.7.2-3
1.7.2-3
znc
Debian:8
before 1.4-2+deb8u2, plus listed versions
1.4-21.4-2+deb8u1
1.4-2+deb8u2
znc
Debian:9
before 1.6.5-1+deb9u2, plus listed versions
1.6.5-11.6.5-1+deb9u1
1.6.5-1+deb9u2
znc
Mageia:6
before 1.7.4-1.mga6
1.7.4-1.mga6
znc
Mageia:7
before 1.7.4-1.mga7
1.7.4-1.mga7
znc
Ubuntu:Pro:14.04:LTS
before 1.2-3ubuntu0.1+esm1, plus listed versions
1.0-51.0-5build11.2-11.2-21.2-31.2-3build11.2-3ubuntu0.1
1.2-3ubuntu0.1+esm1
znc
Ubuntu:16.04:LTS
before 1.6.3-1ubuntu0.2, plus listed versions
1.6.1-11.6.1-1build11.6.1-21.6.2-11.6.2-21.6.2-2build11.6.3-11.6.3-1ubuntu0.1
1.6.3-1ubuntu0.2
znc
Ubuntu:18.04:LTS
before 1.6.6-1ubuntu0.2, plus listed versions
1.6.5-2build21.6.5-2build31.6.5-2build41.6.5-2build51.6.6-11.6.6-1ubuntu0.1
1.6.6-1ubuntu0.2
znc
SUSE:Package Hub 15
before 1.7.4-bp150.2.6.1
1.7.4-bp150.2.6.1
znc
openSUSE:Leap 15.0
before 1.7.4-bp150.2.6.1
1.7.4-bp150.2.6.1
znc
openSUSE:Leap 15.1
before 1.7.4-bp150.2.6.1
1.7.4-bp150.2.6.1
znc
SUSE:Package Hub 15 SP1
before 1.7.4-bp151.4.3.1
1.7.4-bp151.4.3.1
znc
openSUSE:Tumbleweed
before 1.8.2-1.11
1.8.2-1.11

History

History
RecordedChangedSources
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-12816 is a high vulnerability (CVSS 8.8) in Znc, published June 14, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.05%, the 90th percentile. Fixed in znc 1.7.4-r0.

References

Show 28 moreShow less
MoveEnter Open