CVE-2017-1000159
Command injection in evince via filename when printing to PDF. This affects versions earlier than...
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
- Record
CVE-2017-1000159- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
- Record
CVE-2017-1000159- Updated
- 2026-11-02
EUVDEUVD-2017-1444 No score
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
- Record
EUVD-2017-1444- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vvj5-83p2-x3pp
7.8
Command injection in evince via filename when printing to PDF. This affects versions earlier than...
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
- Record
GHSA-vvj5-83p2-x3pp- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
7.8
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
- Record
CVE-2017-1000159- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-1000159
7.8
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
- Record
DEBIAN-CVE-2017-1000159- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2017-1000159
7.8
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
- Record
UBUNTU-CVE-2017-1000159- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0450 No score
Updated evince packages fix security vulnerability
It was discovered that Evince incorrectly handled printing certain DVI files. If a user were tricked into opening and printing a specially-named DVI file, an attacker could use this issue to execute arbitrary code (CVE-2017-1000159)
- Record
MGASA-2017-0450- Updated
- 2026-11-02
OSVSUSE-SU-2018:0639-1 No score
Security update for evince
This update for evince provides the following fix:
- CVE-2017-1000159: Prevent command line injections via filenames when printing to a file. (bsc#1070046)
- Record
SUSE-SU-2018:0639-1- Updated
- 2026-11-02
OSVSUSE-SU-2018:0947-1 No score
Security update for evince
This update for evince fixes the following issues:
- CVE-2017-1000159: Command injection in evince via filename when printing to PDF could lead to command execution (bsc#1070046)
- Record
SUSE-SU-2018:0947-1- Updated
- 2026-11-02
OSVUSN-3503-1 No score
evince vulnerability
It was discovered that Evince incorrectly handled printing certain DVI files. If a user were tricked into opening and printing a specially-named DVI file, an attacker could use this issue to execute arbitrary code.
- Record
USN-3503-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
atrilDebian:12 |
before 1.20.0-1 | 1.20.0-1 |
atrilDebian:13 |
before 1.20.0-1 | 1.20.0-1 |
atrilDebian:14 |
before 1.20.0-1 | 1.20.0-1 |
evinceDebian:12 |
before 3.25.92-1 | 3.25.92-1 |
evinceDebian:13 |
before 3.25.92-1 | 3.25.92-1 |
evinceDebian:7 |
before 3.4.0-3.1+deb7u2, plus listed versions 3.4.0-3.13.4.0-3.1+deb7u1 |
3.4.0-3.1+deb7u2 |
evinceDebian:8 From an advisory covering 3 CVEs |
before 3.14.1-2+deb8u3, plus listed versions 3.14.1-23.14.1-2+deb8u13.14.1-2+deb8u2 |
3.14.1-2+deb8u3 |
atrilDebian:8 From an advisory covering 3 CVEs |
before 1.8.1+dfsg1-4+deb8u2, plus listed versions 1.8.1+dfsg1-41.8.1+dfsg1-4+deb8u1 |
1.8.1+dfsg1-4+deb8u2 |
evinceDebian:9 From an advisory covering 3 CVEs |
before 3.22.1-3+deb9u2, plus listed versions 3.22.1-33.22.1-3+deb9u1 |
3.22.1-3+deb9u2 |
evinceMageia:5 |
before 3.14.2-2.1.mga5 | 3.14.2-2.1.mga5 |
Show 12 moreShow less
| Package | Affected | Fixed |
|---|---|---|
evinceMageia:6 |
before 3.24.1-2.mga6 | 3.24.1-2.mga6 |
evinceSUSE:Linux Enterprise Software Development Kit 11 SP4 |
before 2.28.2-0.7.3.1 | 2.28.2-0.7.3.1 |
evinceSUSE:Linux Enterprise Server 11 SP4 |
before 2.28.2-0.7.3.1 | 2.28.2-0.7.3.1 |
evinceSUSE:Linux Enterprise Server for SAP Applications 11 SP4 |
before 2.28.2-0.7.3.1 | 2.28.2-0.7.3.1 |
evinceSUSE:Linux Enterprise Desktop 12 SP3 |
before 3.20.2-6.22.9 | 3.20.2-6.22.9 |
evinceSUSE:Linux Enterprise Software Development Kit 12 SP3 |
before 3.20.2-6.22.9 | 3.20.2-6.22.9 |
evinceSUSE:Linux Enterprise Server 12 SP3 |
before 3.20.2-6.22.9 | 3.20.2-6.22.9 |
evinceSUSE:Linux Enterprise Server for SAP Applications 12 SP3 |
before 3.20.2-6.22.9 | 3.20.2-6.22.9 |
evinceSUSE:Linux Enterprise Workstation Extension 12 SP3 |
before 3.20.2-6.22.9 | 3.20.2-6.22.9 |
evinceUbuntu:14.04:LTS |
before 3.10.3-0ubuntu10.4, plus listed versions 3.10.0-0ubuntu23.10.0-0ubuntu33.10.2-0ubuntu13.10.3-0ubuntu13.10.3-0ubuntu2 Show 11 moreShow less3.10.3-0ubuntu33.10.3-0ubuntu43.10.3-0ubuntu53.10.3-0ubuntu63.10.3-0ubuntu73.10.3-0ubuntu83.10.3-0ubuntu93.10.3-0ubuntu103.10.3-0ubuntu10.13.10.3-0ubuntu10.23.10.3-0ubuntu10.3 |
3.10.3-0ubuntu10.4 |
atrilUbuntu:16.04:LTS |
before 1.12.2-1ubuntu0.3, plus listed versions 1.10.2+repack1-11.12.2-11.12.2-1ubuntu0.11.12.2-1ubuntu0.2 |
1.12.2-1ubuntu0.3 |
evinceUbuntu:16.04:LTS |
before 3.18.2-1ubuntu4.3, plus listed versions 3.16.1-0ubuntu13.18.1-1ubuntu13.18.1-1ubuntu23.18.2-1ubuntu13.18.2-1ubuntu2 Show 4 moreShow less3.18.2-1ubuntu33.18.2-1ubuntu43.18.2-1ubuntu4.13.18.2-1ubuntu4.2 |
3.18.2-1ubuntu4.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000159 is a high vulnerability (CVSS 7.8) in Gnome Evince, published November 27, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.41%, the 72nd percentile. Fixed in atril 1.20.0-1.
References
security.gentoo.org/glsa/201804-15
lists.debian.org/debian-lts-announce/2017/12/msg00006.html
bugzilla.gnome.org/show_bug.cgi?id=784947
lists.debian.org/debian-lts-announce/2019/08/msg00013.html
lists.debian.org/debian-lts-announce/2019/08/msg00014.html
debian.org/security/2020/dsa-4624
Show 15 moreShow less
seclists.org/bugtraq/2020/Feb/18
nvd.nist.gov/vuln/detail/CVE-2017-1000159
github.com/advisories/GHSA-vvj5-83p2-x3pp
security-tracker.debian.org/tracker/CVE-2017-1000159
advisories.mageia.org/MGASA-2017-0450.html
bugs.mageia.org/show_bug.cgi?id=22131
cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000159
usn.ubuntu.com/usn/usn-3503-1
suse.com/support/update/announcement/2018/suse-su-20180639-1
bugzilla.suse.com/1070046
suse.com/security/cve/CVE-2017-1000159
suse.com/support/update/announcement/2018/suse-su-20180947-1
ubuntu.com/security/CVE-2017-1000159
ubuntu.com/security/notices/USN-3503-1
cve.org/CVERecord?id=CVE-2017-1000159