CVE-2015-0885
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via...
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via a -- (dash dash) in a username.
Exploit likelihood
What each source reports
NVD Score used
5.0
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via a -- (dash dash) in a username.
- Record
CVE-2015-0885- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-399
- Updated
- 2026-11-02
CVE List No score
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via a -- (dash dash) in a username.
- Record
CVE-2015-0885- Updated
- 2026-11-02
EUVDEUVD-2015-0895 No score
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via a -- (dash dash) in a username.
- Record
EUVD-2015-0895- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7vf6-5275-97j2 No score
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via...
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via a -- (dash dash) in a username.
- Record
GHSA-7vf6-5275-97j2- Updated
- 2026-11-02
OSV No score
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via a -- (dash dash) in a username.
- Record
CVE-2015-0885- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-0885 No score
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via a -- (dash dash) in a username.
- Record
DEBIAN-CVE-2015-0885- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-0885 No score
checkpw 1.02 and earlier allows remote attackers to cause a denial of service (infinite loop) via a -- (dash dash) in a username.
- Record
UBUNTU-CVE-2015-0885- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
checkpwDebian:12 |
before 1.02-1.1 | 1.02-1.1 |
checkpwDebian:13 |
before 1.02-1.1 | 1.02-1.1 |
checkpwDebian:6.0 |
before 1.02-1+deb6u1, plus listed versions 1.02-1 |
1.02-1+deb6u1 |
checkpwDebian:7 |
before 1.02-1+deb7u1, plus listed versions 1.02-1 |
1.02-1+deb7u1 |
checkpwUbuntu:14.04:LTS |
before 1.02-1+deb6u1build0.14.04.1, plus listed versions 1.02-1 |
1.02-1+deb6u1build0.14.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-0885 is a medium vulnerability (CVSS 5.0) in Checkpw Project Checkpw, published February 28, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.43%, the 84th percentile. Fixed in checkpw 1.02-1.1.