Every CVE Search/ Get API key

CVE-2015-6673

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

9.8 CriticalFix available

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.91%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Record
CVE-2015-6673
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Record
CVE-2015-6673
Updated
2026-11-02
EUVDEUVD-2015-6611 No score

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Record
EUVD-2015-6611
Updated
2026-11-03
GitHub AdvisoriesGHSA-2v33-9pfj-w95c 9.8

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Record
GHSA-2v33-9pfj-w95c
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-416
Updated
2026-11-02
OSV 9.8

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Record
CVE-2015-6673
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-6673 9.8

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Record
DEBIAN-CVE-2015-6673
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2015-6673 9.8

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

Record
UBUNTU-CVE-2015-6673
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0014 No score

Updated libpgf packages fix security vulnerability

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32 (CVE-2015-6673).

Record
MGASA-2019-0014
Updated
2026-11-02
OSVopenSUSE-SU-2024:10298-1 No score

libpgf-devel-6.14.12-4.6 on GA media

These are all security issues fixed in the libpgf-devel-6.14.12-4.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10298-1
Updated
2026-11-02
OSVUSN-4554-1 No score

libpgf vulnerability

It was discovered that libPGF lacked proper validation when opening a specially crafted PGF file. An attacker could possibly use this issue to cause a denial of service.

Record
USN-4554-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libpgf
Debian:12
before 6.14.12-3.2
6.14.12-3.2
libpgf
Debian:13
before 6.14.12-3.2
6.14.12-3.2
libpgf
Debian:14
before 6.14.12-3.2
6.14.12-3.2
libpgf
Debian:8
before 6.14.12-3+deb8u1, plus listed versions
6.14.12-3
6.14.12-3+deb8u1
libpgf
Mageia:6
before 6.12.24-7.1.mga6
6.12.24-7.1.mga6
libpgf
Ubuntu:16.04:LTS
before 6.14.12-3.1ubuntu0.1, plus listed versions
6.14.12-36.14.12-3.1
6.14.12-3.1ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-6673 is a critical vulnerability (CVSS 9.8) in Libpgf, published September 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.91%, the 79th percentile. Fixed in libpgf 6.14.12-3.2.

References

Show 11 moreShow less
MoveEnter Open