CVE-2015-0258
Multiple incomplete blacklist vulnerabilities in the avatar upload functionality in manageuser...
Multiple incomplete blacklist vulnerabilities in the avatar upload functionality in manageuser.php in Collabtive before 2.1 allow remote authenticated users to execute arbitrary code by uploading a file with a (1) .php3, (2) .php4, (3) .php5, or (4) .phtml extension.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Multiple incomplete blacklist vulnerabilities in the avatar upload functionality in manageuser.php in Collabtive before 2.1 allow remote authenticated users to execute arbitrary code by uploading a file with a (1) .php3, (2) .php4, (3) .php5, or (4) .phtml extension.
- Record
CVE-2015-0258- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-434
- Updated
- 2026-11-02
CVE List No score
Multiple incomplete blacklist vulnerabilities in the avatar upload functionality in manageuser.php in Collabtive before 2.1 allow remote authenticated users to execute arbitrary code by uploading a file with a (1) .php3, (2) .php4, (3) .php5, or (4) .phtml extension.
- Record
CVE-2015-0258- Updated
- 2026-11-02
EUVDEUVD-2015-0278 No score
Multiple incomplete blacklist vulnerabilities in the avatar upload functionality in manageuser.php in Collabtive before 2.1 allow remote authenticated users to execute arbitrary code by uploading a file with a (1) .php3, (2) .php4, (3) .php5, or (4) .phtml extension.
- Record
EUVD-2015-0278- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2hf9-vh2r-j6vp No score
Multiple incomplete blacklist vulnerabilities in the avatar upload functionality in manageuser...
Multiple incomplete blacklist vulnerabilities in the avatar upload functionality in manageuser.php in Collabtive before 2.1 allow remote authenticated users to execute arbitrary code by uploading a file with a (1) .php3, (2) .php4, (3) .php5, or (4) .phtml extension.
- Record
GHSA-2hf9-vh2r-j6vp- Weakness
- CWE-434
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-0258
8.8
Multiple incomplete blacklist vulnerabilities in the avatar upload functionality in manageuser.php in Collabtive before 2.1 allow remote authenticated users to execute arbitrary code by uploading a file with a (1) .php3, (2) .php4, (3) .php5, or (4) .phtml extension.
- Record
UBUNTU-CVE-2015-0258- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4590-1 No score
collabtive vulnerability
It was discovered that Collabtive did not properly validate avatar image file uploads. An authenticated user could exploit this with a crafted file to cause Collabtive to execute arbitrary code. (CVE-2015-0258)
- Record
USN-4590-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
collabtiveDebian:8 |
before 2.0+dfsg-5+deb8u1, plus listed versions 2.0+dfsg-5 |
2.0+dfsg-5+deb8u1 |
collabtiveUbuntu:16.04:LTS |
before 2.0+dfsg-6ubuntu1.1, plus listed versions 2.0+dfsg-62.0+dfsg-6ubuntu1 |
2.0+dfsg-6ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-0258 is a high vulnerability (CVSS 8.8) in O-dyn Collabtive, published February 17, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.78%, the 89th percentile. Fixed in collabtive 2.0+dfsg-5+deb8u1.
References
packetstormsecurity.com/files/133736/Collabtive-2.0-Shell-Upload.html
github.com/philippK-de/Collabtive/commit/9ce6301583669d0a8ecb4d23fb56e34b68511335
lists.debian.org/debian-lts-announce/2020/02/msg00031.html
usn.ubuntu.com/4590-1
nvd.nist.gov/vuln/detail/CVE-2015-0258
github.com/advisories/GHSA-2hf9-vh2r-j6vp
ubuntu.com/security/CVE-2015-0258
ubuntu.com/security/notices/USN-4590-1
cve.org/CVERecord?id=CVE-2015-0258