CVE-2019-10064
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library...
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
- Record
CVE-2019-10064- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-331
- Updated
- 2026-11-02
CVE List No score
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
- Record
CVE-2019-10064- Updated
- 2026-11-02
EUVDEUVD-2019-2125 No score
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
- Record
EUVD-2019-2125- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h5p7-cpc2-2j2r No score
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library...
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
- Record
GHSA-h5p7-cpc2-2j2r- Weakness
- CWE-331
- Updated
- 2026-11-02
OSV
7.5
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
- Record
CVE-2019-10064- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-04
OSVDEBIAN-CVE-2019-10064
7.5
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
- Record
DEBIAN-CVE-2019-10064- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-10064
7.5
hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
- Record
UBUNTU-CVE-2019-10064- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2026:12398-1 No score
hostapd-2.12-1.1 on GA media
These are all security issues fixed in the hostapd-2.12-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:12398-1- Updated
- 2026-11-04
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wpaDebian:12 |
before 2:2.6-7 | 2:2.6-7 |
wpaDebian:13 |
before 2:2.6-7 | 2:2.6-7 |
wpaDebian:14 |
before 2:2.6-7 | 2:2.6-7 |
wpaDebian:8 |
before 2.3-1+deb8u10, plus listed versions 2.3-12.3-1+deb8u12.3-1+deb8u22.3-1+deb8u32.3-1+deb8u4 Show 5 moreShow less2.3-1+deb8u52.3-1+deb8u62.3-1+deb8u72.3-1+deb8u82.3-1+deb8u9 |
2.3-1+deb8u10 |
wpaDebian:9 From an advisory covering 2 CVEs |
before 2:2.4-1+deb9u7, plus listed versions 2:2.4-12:2.4-1+deb9u12:2.4-1+deb9u22:2.4-1+deb9u32:2.4-1+deb9u42:2.4-1+deb9u6 |
2:2.4-1+deb9u7 |
wpaUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 1.0-3ubuntu21.0-3ubuntu31.0-3ubuntu42.1-0ubuntu12.1-0ubuntu1.1 Show 11 moreShow less2.1-0ubuntu1.22.1-0ubuntu1.32.1-0ubuntu1.42.1-0ubuntu1.52.1-0ubuntu1.62.1-0ubuntu1.72.1-0ubuntu1.7+esm12.1-0ubuntu1.7+esm22.1-0ubuntu1.7+esm32.1-0ubuntu1.7+esm42.1-0ubuntu1.7+esm5 |
None known |
wpaUbuntu:16.04:LTS |
All versions, plus listed versions 2.4-0ubuntu32.4-0ubuntu42.4-0ubuntu52.4-0ubuntu62.4-0ubuntu6.2 Show 7 moreShow less2.4-0ubuntu6.32.4-0ubuntu6.42.4-0ubuntu6.52.4-0ubuntu6.62.4-0ubuntu6.72.4-0ubuntu6.82.4-0ubuntu6.8+esm1 |
None known |
hostapdopenSUSE:Tumbleweed From an advisory covering 3 CVEs |
before 2.12-1.1 | 2.12-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| affected, aliases, facts, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-10064 is a high vulnerability (CVSS 7.5) in W1.fi Hostapd, published February 28, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.87%, the 90th percentile. Fixed in wpa 2:2.6-7.
References
w1.fi/cgit/hostap/commit?id=98a516eae8260e6fd5c48ddecf8d006285da7389
openwall.com/lists/oss-security/2020/02/27/1
openwall.com/lists/oss-security/2020/02/27/2
seclists.org/fulldisclosure/2020/Feb/26
packetstormsecurity.com/files/156573/Hostapd-Insufficient-Entropy.html
lists.debian.org/debian-lts-announce/2020/03/msg00010.html
Show 9 moreShow less
lists.debian.org/debian-lts-announce/2020/08/msg00013.html
nvd.nist.gov/vuln/detail/CVE-2019-10064
github.com/advisories/GHSA-h5p7-cpc2-2j2r
security-tracker.debian.org/tracker/CVE-2019-10064
ubuntu.com/security/CVE-2019-10064
cve.org/CVERecord?id=CVE-2019-10064
suse.com/security/cve/CVE-2019-10064
suse.com/security/cve/CVE-2019-5061
suse.com/security/cve/CVE-2022-37660