CVE-2020-17446
Asyncpg Arbitrary Code Execution Via Access to an Uninitialized Pointer
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
CVE-2020-17446- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-824
- Updated
- 2026-11-02
CVE List No score
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
CVE-2020-17446- Updated
- 2026-11-02
EUVDEUVD-2020-0048 No score
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
EUVD-2020-0048- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2xpj-f5g2-8p7m
9.3
Asyncpg Arbitrary Code Execution Via Access to an Uninitialized Pointer
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
GHSA-2xpj-f5g2-8p7m- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-824
- Updated
- 2026-11-02
OSV
9.8
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
CVE-2020-17446- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-17446
9.8
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
DEBIAN-CVE-2020-17446- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 6 moreShow less
OSVGHSA-2xpj-f5g2-8p7m
9.3
Asyncpg Arbitrary Code Execution Via Access to an Uninitialized Pointer
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
GHSA-2xpj-f5g2-8p7m- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-824
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-17446
9.8
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
UBUNTU-CVE-2020-17446- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11215-1 No score
python38-asyncpg-0.22.0-2.2 on GA media
These are all security issues fixed in the python38-asyncpg-0.22.0-2.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11215-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:14132-1 No score
python310-asyncpg-0.29.0-1.3 on GA media
These are all security issues fixed in the python310-asyncpg-0.29.0-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:14132-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:11998-1 No score
python313-asyncpg-0.31.0-1.4 on GA media
These are all security issues fixed in the python313-asyncpg-0.31.0-1.4 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:11998-1- Updated
- 2026-11-02
OSVPYSEC-2020-24 No score
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
- Record
PYSEC-2020-24- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
asyncpgPyPI |
before 0.21.0 | 0.21.0 |
asyncpgDebian:12 |
before 0.21.0-1 | 0.21.0-1 |
asyncpgDebian:13 |
before 0.21.0-1 | 0.21.0-1 |
asyncpgDebian:14 |
before 0.21.0-1 | 0.21.0-1 |
asyncpgDebian:9 |
before 0.8.4-1+deb9u1, plus listed versions 0.8.4-1 |
0.8.4-1+deb9u1 |
asyncpgPyPI |
before 0.21.0, plus listed versions 0.10.00.10.10.11.00.12.00.13.0 Show 27 moreShow less0.14.00.15.00.16.00.17.00.18.00.18.10.18.20.18.30.19.00.20.00.20.10.5.00.5.10.5.20.5.30.5.40.6.10.6.20.6.30.7.00.8.00.8.10.8.20.8.30.8.40.9.00.9.0.dev1 |
0.21.0 |
asyncpgPyPI |
before 0.21.0, plus listed versions 0.5.00.5.10.5.20.5.30.5.4 Show 27 moreShow less0.6.10.6.20.6.30.7.00.8.00.8.10.8.20.8.30.8.40.9.0.dev10.9.00.10.00.10.10.11.00.12.00.13.00.14.00.15.00.16.00.17.00.18.00.18.10.18.20.18.30.19.00.20.00.20.1 |
0.21.0 |
asyncpgUbuntu:18.04:LTS |
All versions, plus listed versions 0.12.0-1ubuntu30.13.0-1ubuntu3 |
None known |
asyncpgUbuntu:20.04:LTS |
All versions, plus listed versions 0.13.0-1ubuntu50.20.0-10.20.0-1build1 |
None known |
python-asyncpgopenSUSE:Tumbleweed |
before 0.29.0-1.3 | 0.29.0-1.3 |
python-asyncpgopenSUSE:Tumbleweed |
before 0.31.0-1.4 | 0.31.0-1.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-17446 is a critical vulnerability (CVSS 9.8) in Magic Asyncpg, published August 12, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.42%, the 84th percentile. Fixed in asyncpg 0.21.0.
References
github.com/MagicStack/asyncpg/releases/tag/v0.21.0
lists.debian.org/debian-lts-announce/2020/09/msg00002.html
nvd.nist.gov/vuln/detail/CVE-2020-17446
github.com/MagicStack/asyncpg/commit/69bcdf5bf7696b98ee708be5408fd7d854e910d0
github.com/advisories/GHSA-2xpj-f5g2-8p7m
github.com/pypa/advisory-database/tree/main/vulns/asyncpg/PYSEC-2020-24.yaml