CVE-2019-17637
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files...
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files referring to external entities could be exploited to send the contents of local files to a remote server when edited or validated, even when external entity resolution is disabled in the user preferences.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.1
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files referring to external entities could be exploited to send the contents of local files to a remote server when edited or validated, even when external entity resolution is disabled in the user preferences.
- Record
CVE-2019-17637- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:N - Weakness
- CWE-611
- Updated
- 2026-11-02
CVE List No score
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files referring to external entities could be exploited to send the contents of local files to a remote server when edited or validated, even when external entity resolution is disabled in the user preferences.
- Record
CVE-2019-17637- Weakness
- CWE-611
- Updated
- 2026-11-02
EUVDEUVD-2019-7948 No score
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files referring to external entities could be exploited to send the contents of local files to a remote server when edited or validated, even when external entity resolution is disabled in the user preferences.
- Record
EUVD-2019-7948- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wm24-pc4h-hw9q
7.1
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files...
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files referring to external entities could be exploited to send the contents of local files to a remote server when edited or validated, even when external entity resolution is disabled in the user preferences.
- Record
GHSA-wm24-pc4h-hw9q- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-611
- Updated
- 2026-11-02
OSV
7.1
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files referring to external entities could be exploited to send the contents of local files to a remote server when edited or validated, even when external entity resolution is disabled in the user preferences.
- Record
CVE-2019-17637- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-17637
7.1
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files referring to external entities could be exploited to send the contents of local files to a remote server when edited or validated, even when external entity resolution is disabled in the user preferences.
- Record
DEBIAN-CVE-2019-17637- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-17637
7.1
In all versions of Eclipse Web Tools Platform through release 3.18 (2020-06), XML and DTD files referring to external entities could be exploited to send the contents of local files to a remote server when edited or validated, even when external entity resolution is disabled in the user preferences.
- Record
UBUNTU-CVE-2019-17637- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
eclipse-wtpDebian:12 |
before 3.18-1 | 3.18-1 |
eclipse-wtpDebian:14 |
before 3.18-1, plus listed versions 3.4.1-13.4.1-23.4.2-13.4.2-23.4.2-3 Show 8 moreShow less3.5.0-13.5.1-13.5.1-23.5.2-13.6.0-13.6.3-13.6.3-23.6.3-3 |
3.18-1 |
eclipse-wtpDebian:9 |
before 3.6.3-3+deb9u1, plus listed versions 3.6.3-3 |
3.6.3-3+deb9u1 |
eclipse-wtpUbuntu:16.04:LTS |
All versions, plus listed versions 3.6.3-1 |
None known |
eclipse-wtpUbuntu:18.04:LTS |
All versions, plus listed versions 3.6.3-3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-17637 is a high vulnerability (CVSS 7.1) in Eclipse Web Tools Platform, published July 15, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.88%, the 59th percentile. Fixed in eclipse-wtp 3.18-1.
References
bugs.eclipse.org/bugs/show_bug.cgi?id=458571
lists.debian.org/debian-lts-announce/2020/10/msg00016.html
nvd.nist.gov/vuln/detail/CVE-2019-17637
github.com/advisories/GHSA-wm24-pc4h-hw9q
security-tracker.debian.org/tracker/CVE-2019-17637
ubuntu.com/security/CVE-2019-17637
cve.org/CVERecord?id=CVE-2019-17637