Every CVE Search/ Get API key

CVE-2020-35573

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU...

7.5 HighFix available

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.69%Up 1.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Record
CVE-2020-35573
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-834
Updated
2026-11-02
CVE List No score

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Record
CVE-2020-35573
Updated
2026-11-02
EUVDEUVD-2020-23239 No score

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Record
EUVD-2020-23239
Updated
2026-11-03
GitHub AdvisoriesGHSA-vcpj-66gx-c27m 7.5

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU...

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Record
GHSA-vcpj-66gx-c27m
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400, CWE-834
Updated
2026-11-02
OSVALPINE-CVE-2020-35573 7.5

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Record
ALPINE-CVE-2020-35573
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSV 7.5

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Record
CVE-2020-35573
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 7 moreShow less
OSVDEBIAN-CVE-2020-35573 7.5

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Record
DEBIAN-CVE-2020-35573
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-35573 7.5

srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.

Record
UBUNTU-CVE-2020-35573
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2021:0646-1 No score

Security update for postsrsd

This update for postsrsd fixes the following issues:

Update to release 1.11 [boo#1180251]

  • Drop group privileges as well as user privileges
  • Fixed: The subprocess that talks to Postfix could be caused to hang with a very long email address. [CVE-2020-35573]

Update to release 1.6

  • Fix endianness issue with SHA-1 implementation
  • Add dual stack support
  • Make SRS separator configurable
Record
openSUSE-SU-2021:0646-1
Updated
2026-11-02
OSVopenSUSE-SU-2021:0669-1 No score

Security update for postsrsd

This update for postsrsd fixes the following issues:

Update to release 1.11 [boo#1180251]

  • Drop group privileges as well as user privileges
  • Fixed: The subprocess that talks to Postfix could be caused to hang with a very long email address. [CVE-2020-35573]

Update to release 1.6

  • Fix endianness issue with SHA-1 implementation
  • Add dual stack support
  • Make SRS separator configurable

This update was imported from the openSUSE:Leap:15.2:Update update project.

Record
openSUSE-SU-2021:0669-1
Updated
2026-11-02
OSVopenSUSE-SU-2021:1642-1 No score

Security update for postrsd

postrsd was updated to release 1.11 [boo#1180251]:

  • Drop group privileges as well as user privileges
  • Fixed: The subprocess that talks to Postfix could be caused to hang with a very long email address. [CVE-2020-35573]
  • Update to release 1.6

    • Fix endianness issue with SHA-1 implementation
    • Add dual stack support
    • Make SRS separator configurable
Record
openSUSE-SU-2021:1642-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11188-1 No score

postsrsd-1.11-1.3 on GA media

These are all security issues fixed in the postsrsd-1.11-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11188-1
Updated
2026-11-02
OSVUSN-4730-1 No score

postsrsd vulnerability

It was discovered that PostSRSd mishandled certain input. A remote attacker could use this vulnerability to cause a denial of service via a long timestamp tag in an SRS address.

Record
USN-4730-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postsrsd
Alpine:v3.12
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.13
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.14
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.15
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.16
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.17
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.18
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.19
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.20
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.21
before 1.6-r4
1.6-r4
Show 16 moreShow less
Affected packages
PackageAffectedFixed
postsrsd
Alpine:v3.22
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.23
before 1.6-r4
1.6-r4
postsrsd
Alpine:v3.24
before 1.6-r4
1.6-r4
postsrsd
Debian:12
before 1.10-1
1.10-1
postsrsd
Debian:13
before 1.10-1
1.10-1
postsrsd
Debian:14
before 1.10-1
1.10-1
postsrsd
Debian:9
before 1.4-1+deb9u1, plus listed versions
1.4-1
1.4-1+deb9u1
postsrsd
Ubuntu:16.04:LTS
All versions, plus listed versions
1.2-1
None known
postsrsd
Ubuntu:18.04:LTS
before 1.4-1ubuntu0.1, plus listed versions
1.4-1
1.4-1ubuntu0.1
postsrsd
Ubuntu:20.04:LTS
All versions, plus listed versions
1.5-2
None known
postsrsd
Ubuntu:22.04:LTS
All versions, plus listed versions
1.10-2
None known
postsrsd
openSUSE:Leap 15.2
before 1.11-lp152.4.3.1
1.11-lp152.4.3.1
postsrsd
SUSE:Package Hub 15 SP2
before 1.11-bp152.4.3.1
1.11-bp152.4.3.1
postsrsd
SUSE:Package Hub 15 SP3
before 1.11-bp153.2.3.1
1.11-bp153.2.3.1
postsrsd
openSUSE:Leap 15.3
before 1.11-bp153.2.3.1
1.11-bp153.2.3.1
postsrsd
openSUSE:Tumbleweed
before 1.11-1.3
1.11-1.3

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-35573 is a high vulnerability (CVSS 7.5) in Postsrsd Project Postsrsd, published December 20, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.69%, the 85th percentile. Fixed in postsrsd 1.6-r4.

References

Show 9 moreShow less
MoveEnter Open