Every CVE Search/ Get API key

CVE-2021-25801

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11...

7.1 HighPublic exploitFix available

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

1.52%Up 1.1 points since Jul 27, 2021
90%50%10%1%

What each source reports

NVD Score used 7.1

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

Record
CVE-2021-25801
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

Record
CVE-2021-25801
Updated
2026-11-02
EUVDEUVD-2021-12684 No score

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

Record
EUVD-2021-12684
Updated
2026-11-03
GitHub AdvisoriesGHSA-vwcj-ffx4-g5rx 7.1

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11...

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

Record
GHSA-vwcj-ffx4-g5rx
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-120, CWE-125
Updated
2026-11-02
OSV 7.1

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

Record
CVE-2021-25801
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-25801 7.1

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

Record
DEBIAN-CVE-2021-25801
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-25801 7.1

A buffer overflow vulnerability in the __Parse_indx component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

Record
UBUNTU-CVE-2021-25801
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUSN-6180-1 No score

vlc vulnerabilities

It was discovered that VLC could be made to read out of bounds when decoding image files. If a user were tricked into opening a crafted image file, a remote attacker could possibly use this issue to cause VLC to crash, leading to a denial of service. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2019-19721)

It was discovered that VLC could be made to write out of bounds when processing H.264 video files. If a user were tricked into opening a crafted H.264 video file, a remote attacker could possibly use this issue to cause VLC to crash, leading to a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-13428)

It was discovered that VLC could be made to read out of bounds when processing AVI video files. If a user were tricked into opening a crafted AVI video file, a remote attacker could possibly use this issue to cause VLC to crash, leading to a denial of service. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2021-25801, CVE-2021-25802, CVE-2021-25803, CVE-2021-25804)

It was discovered that the VNC module of VLC contained an arithmetic overflow. If a user were tricked into opening a crafted playlist or connecting to a rouge VNC server, a remote attacker could possibly use this issue to cause VLC to crash, leading to a denial of service, or possibly execute arbitrary code. (CVE-2022-41325)

Record
USN-6180-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vlc
Debian:12
before 3.0.12-1
3.0.12-1
vlc
Debian:13
before 3.0.12-1
3.0.12-1
vlc
Debian:14
before 3.0.12-1
3.0.12-1
vlc
Debian:9
before 3.0.11-0+deb9u2, plus listed versions
2.2.6-12.2.6-1~deb9u12.2.6-22.2.6-32.2.6-4
Show 45 moreShow less
2.2.6-52.2.6-62.2.7-12.2.7-1~deb8u12.2.7-1~deb9u12.2.8-12.2.8-23.0.0-13.0.0~rc1-13.0.0~rc1~20171206-13.0.0~rc1~20171210-13.0.0~rc1~20171210-23.0.0~rc2-13.0.0~rc2-23.0.0~rc4-13.0.0~rc4-23.0.0~rc4-33.0.0~rc5-13.0.0~rc6-13.0.0~rc7-13.0.0~rc7-23.0.0~rc8-13.0.1-13.0.1-23.0.1-33.0.10-0+deb9u13.0.10-13.0.10-23.0.11-0+deb9u13.0.2-0+deb9u13.0.2-13.0.2-1+0.riscv64.13.0.2-1+0.riscv64.23.0.3-13.0.3-1+0.riscv64.13.0.3-1+b1+0.riscv64.13.0.3-1-0+deb9u13.0.3-1-13.0.3-1-23.0.3-1-33.0.3-1-43.0.3-23.0.4-13.0.4-23.0.4-3
3.0.11-0+deb9u2
vlc
Debian:10
before 3.0.12-0+deb10u1, plus listed versions
3.0.10-0+deb10u13.0.10-13.0.10-23.0.11-0+deb10u13.0.11-1
Show 18 moreShow less
3.0.11-23.0.11-33.0.11-3~exp13.0.11-3~exp23.0.11-43.0.11.1-13.0.11.1-23.0.11.1-33.0.7-13.0.7.1-13.0.7.1-23.0.7.1-33.0.8-0+deb10u13.0.8-13.0.8-23.0.8-33.0.8-43.0.9.2-1
3.0.12-0+deb10u1
vlc
Ubuntu:Pro:16.04:LTS
before 2.2.2-5ubuntu0.16.04.5+esm2, plus listed versions
2.2.1-32.2.1-52.2.2-12.2.2-22.2.2-3
Show 8 moreShow less
2.2.2-3build12.2.2-42.2.2-52.2.2-5ubuntu0.16.04.12.2.2-5ubuntu0.16.04.22.2.2-5ubuntu0.16.04.32.2.2-5ubuntu0.16.04.42.2.2-5ubuntu0.16.04.5+esm1
2.2.2-5ubuntu0.16.04.5+esm2
vlc
Ubuntu:Pro:18.04:LTS
before 3.0.8-0ubuntu18.04.1+esm1, plus listed versions
2.2.6-62.2.6-6build12.2.7-12.2.8-12.2.8-1ubuntu4
Show 20 moreShow less
2.2.8-23.0.0~rc1-1ubuntu13.0.0~rc1-1ubuntu33.0.0~rc2-1ubuntu13.0.0~rc2-2ubuntu13.0.0~rc2-2ubuntu23.0.0~rc4-1ubuntu13.0.0~rc7-2ubuntu13.0.0~rc8-1ubuntu13.0.0-1ubuntu13.0.1-1ubuntu53.0.1-2ubuntu13.0.1-2ubuntu23.0.1-33.0.1-3build13.0.2-0ubuntu0.13.0.3-1-1ubuntu13.0.4-1ubuntu0.23.0.7.1-0ubuntu18.04.13.0.8-0ubuntu18.04.1
3.0.8-0ubuntu18.04.1+esm1
vlc
Ubuntu:Pro:20.04:LTS
before 3.0.9.2-1ubuntu0.1~esm1, plus listed versions
3.0.8-23.0.8-2build13.0.8-33.0.8-3build13.0.8-3build23.0.8-3build43.0.8-43.0.9.2-1
3.0.9.2-1ubuntu0.1~esm1
vlc
Ubuntu:Pro:22.04:LTS
before 3.0.16-1ubuntu0.1~esm1, plus listed versions
3.0.16-13.0.16-1build13.0.16-1build23.0.16-1build33.0.16-1build43.0.16-1build53.0.16-1build7
3.0.16-1ubuntu0.1~esm1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubDShankle/VLC_CVE-2021-25801_Analysis2022-04-21

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-25801 is a high vulnerability (CVSS 7.1) in Videolan Vlc Media Player, published January 22, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in vlc 3.0.12-1.

References

Show 7 moreShow less
This page doesn't list everything

Left out here: 16 versions. The JSON record has them.

MoveEnter Open