CVE-2022-28044
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c...
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
- Record
CVE-2022-28044- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
- Record
CVE-2022-28044- Updated
- 2026-11-02
EUVDEUVD-2022-32530 No score
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
- Record
EUVD-2022-32530- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2qww-cm69-c4w4
9.8
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c...
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
- Record
GHSA-2qww-cm69-c4w4- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-28044
9.8
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
- Record
ALPINE-CVE-2022-28044- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVDEBIAN-CVE-2022-28044
9.8
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
- Record
DEBIAN-CVE-2022-28044- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-28044
9.8
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
- Record
UBUNTU-CVE-2022-28044- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
Irzip v0.640 was discovered to contain a heap memory corruption via the component lrzip.c:initialise_control.
- Record
CVE-2022-28044- Updated
- 2026-11-02
OSVUSN-5840-1 No score
lrzip vulnerabilities
It was discovered that Long Range ZIP incorrectly handled pointers. If a user or an automated system were tricked into opening a certain specially crafted ZIP file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2020-25467)
It was discovered that Long Range ZIP incorrectly handled pointers. If a user or an automated system were tricked into opening a certain specially crafted ZIP file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-27345, CVE-2021-27347)
It was discovered that Long Range ZIP incorrectly handled pointers. If a user or an automated system were tricked into opening a certain specially crafted ZIP file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2022-26291)
It was discovered that Long Range ZIP incorrectly handled memory allocation, which could lead to a heap memory corruption. An attacker could possibly use this issue to cause denial of service. This issue affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, and Ubuntu 22.10. (CVE-2022-28044)
- Record
USN-5840-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lrzipAlpine:v3.17 |
before 0.650-r0 | 0.650-r0 |
lrzipAlpine:v3.18 |
before 0.650-r0 | 0.650-r0 |
lrzipAlpine:v3.19 |
before 0.650-r0 | 0.650-r0 |
lrzipAlpine:v3.20 |
before 0.650-r0 | 0.650-r0 |
lrzipAlpine:v3.21 |
before 0.650-r0 | 0.650-r0 |
lrzipAlpine:v3.22 |
before 0.650-r0 | 0.650-r0 |
lrzipAlpine:v3.23 |
before 0.650-r0 | 0.650-r0 |
lrzipAlpine:v3.24 |
before 0.650-r0 | 0.650-r0 |
lrzipDebian:12 |
before 0.650-1 | 0.650-1 |
lrzipDebian:13 |
before 0.650-1 | 0.650-1 |
Show 14 moreShow less
| Package | Affected | Fixed |
|---|---|---|
lrzipDebian:14 |
before 0.650-1 | 0.650-1 |
lrzipDebian:9 |
before 0.631-1+deb9u3, plus listed versions 0.631-10.631-1+deb9u10.631-1+deb9u2 |
0.631-1+deb9u3 |
lrzipDebian:10 From an advisory covering 3 CVEs |
before 0.631+git180528-1+deb10u1, plus listed versions 0.631+git180528-1 |
0.631+git180528-1+deb10u1 |
lrzipDebian:11 From an advisory covering 3 CVEs |
before 0.641-1+deb11u1, plus listed versions 0.641-1 |
0.641-1+deb11u1 |
lrzipUbuntu:Pro:14.04:LTS |
before 0.616-1ubuntu0.1~esm2, plus listed versions 0.608-20.616-10.616-1ubuntu0.1~esm0.616-1ubuntu0.1~esm1 |
0.616-1ubuntu0.1~esm2 |
lrzipUbuntu:Pro:16.04:LTS |
before 0.621-1ubuntu0.1~esm2, plus listed versions 0.621-10.621-1ubuntu0.1~esm1 |
0.621-1ubuntu0.1~esm2 |
lrzipUbuntu:18.04:LTS |
before 0.631-1+deb9u3build0.18.04.1, plus listed versions 0.631-10.631-1+deb9u1build0.18.04.1 |
0.631-1+deb9u3build0.18.04.1 |
lrzipUbuntu:20.04:LTS |
before 0.631+git180528-1+deb10u1build0.20.04.1, plus listed versions 0.631+git180528-10.631+git180528-1build1 |
0.631+git180528-1+deb10u1build0.20.04.1 |
lrzipUbuntu:22.04:LTS |
before 0.651-2ubuntu0.22.04.1, plus listed versions 0.641-10.651-2 |
0.651-2ubuntu0.22.04.1 |
lrzipUbuntu:Pro:14.04:LTS From an advisory covering 6 CVEs |
before 0.616-1ubuntu0.1~esm2, plus listed versions 0.608-20.616-10.616-1ubuntu0.1~esm0.616-1ubuntu0.1~esm1 |
0.616-1ubuntu0.1~esm2 |
lrzipUbuntu:Pro:16.04:LTS From an advisory covering 6 CVEs |
before 0.621-1ubuntu0.1~esm2, plus listed versions 0.621-10.621-1ubuntu0.1~esm1 |
0.621-1ubuntu0.1~esm2 |
lrzipUbuntu:18.04:LTS From an advisory covering 6 CVEs |
before 0.631-1+deb9u3build0.18.04.1, plus listed versions 0.631-10.631-1+deb9u1build0.18.04.1 |
0.631-1+deb9u3build0.18.04.1 |
lrzipUbuntu:20.04:LTS From an advisory covering 6 CVEs |
before 0.631+git180528-1+deb10u1build0.20.04.1, plus listed versions 0.631+git180528-10.631+git180528-1build1 |
0.631+git180528-1+deb10u1build0.20.04.1 |
lrzipUbuntu:22.04:LTS From an advisory covering 6 CVEs |
before 0.651-2ubuntu0.22.04.1, plus listed versions 0.641-10.651-2 |
0.651-2ubuntu0.22.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | OSV | |
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-28044 is a critical vulnerability (CVSS 9.8) in Irzip Project Irzip, published April 15, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.93%, the 80th percentile. Fixed in lrzip 0.650-r0.
References
github.com/ckolivas/lrzip/issues/216
github.com/ckolivas/lrzip/commit/5faf80cd53ecfd16b636d653483144cd12004f46
lists.debian.org/debian-lts-announce/2022/05/msg00016.html
debian.org/security/2022/dsa-5145
nvd.nist.gov/vuln/detail/CVE-2022-28044
github.com/advisories/GHSA-2qww-cm69-c4w4
Show 11 moreShow less
security.alpinelinux.org/vuln/CVE-2022-28044
github.com/CVEProject/cvelistV5/tree/main/cves/2022/28xxx/CVE-2022-28044.json
security-tracker.debian.org/tracker/CVE-2022-28044
ubuntu.com/security/CVE-2022-28044
ubuntu.com/security/notices/USN-5840-1
cve.org/CVERecord?id=CVE-2022-28044
ubuntu.com/security/CVE-2018-5786
ubuntu.com/security/CVE-2020-25467
ubuntu.com/security/CVE-2021-27345
ubuntu.com/security/CVE-2021-27347
ubuntu.com/security/CVE-2022-26291