CVE-2022-44641
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials...
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials can submit crafted XMLRPC requests that cause a recursive XML entity expansion, leading to excessive use of memory on the server and a Denial of Service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials can submit crafted XMLRPC requests that cause a recursive XML entity expansion, leading to excessive use of memory on the server and a Denial of Service.
- Record
CVE-2022-44641- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-776
- Updated
- 2026-11-02
CVE List
6.5
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials can submit crafted XMLRPC requests that cause a recursive XML entity expansion, leading to excessive use of memory on the server and a Denial of Service.
- Record
CVE-2022-44641- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-776
- Updated
- 2026-11-02
EUVDEUVD-2022-47577
6.5
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials can submit crafted XMLRPC requests that cause a recursive XML entity expansion, leading to excessive use of memory on the server and a Denial of Service.
- Record
EUVD-2022-47577- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hj7c-g88c-mq5v
6.5
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials...
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials can submit crafted XMLRPC requests that cause a recursive XML entity expansion, leading to excessive use of memory on the server and a Denial of Service.
- Record
GHSA-hj7c-g88c-mq5v- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-776
- Updated
- 2026-11-02
OSV
6.5
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials can submit crafted XMLRPC requests that cause a recursive XML entity expansion, leading to excessive use of memory on the server and a Denial of Service.
- Record
CVE-2022-44641- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-44641
6.5
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials can submit crafted XMLRPC requests that cause a recursive XML entity expansion, leading to excessive use of memory on the server and a Denial of Service.
- Record
DEBIAN-CVE-2022-44641- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lavaDebian:12 |
before 2023.01-1 | 2023.01-1 |
lavaDebian:14 |
before 2023.01-1, plus listed versions 2018.10-12018.11-12018.11-1~bpo9+12018.5-12018.5-2 Show 26 moreShow less2018.5-32018.5-3~bpo9+12018.5.post1-12018.5.post1-22018.5.post1-2~bpo9+12018.5.post1-32018.5.post1-42019.01-12019.01-22019.01-32019.01-42019.01-52019.10-12020.05-12020.06-12020.06-22020.12-12020.12-22020.12-32020.12-42020.12-52022.01.3-12022.01.3-22022.01.3-32022.01.3-3.12022.10-1 |
2023.01-1 |
lavaDebian:10 |
before 2019.01-5+deb10u2, plus listed versions 2019.01-52019.01-5+deb10u1 |
2019.01-5+deb10u2 |
lavaDebian:11 |
before 2020.12-5+deb11u2, plus listed versions 2020.12-52020.12-5+deb11u1 |
2020.12-5+deb11u2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-44641 is a medium vulnerability (CVSS 6.5) in Linaro Lava, published November 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.07%, the 64th percentile. Fixed in lava 2023.01-1.
References
lists.lavasoftware.org/archives/list/lava-announce%40lists.lavasoftware.org/thread/WHXGQMIZAPW3GCQEXYHC32N2ZAAAIYCY
debian.org/security/2023/dsa-5318
lists.debian.org/debian-lts-announce/2023/01/msg00016.html
nvd.nist.gov/vuln/detail/CVE-2022-44641
lists.lavasoftware.org/archives/list/[email protected]/thread/WHXGQMIZAPW3GCQEXYHC32N2ZAAAIYCY
github.com/advisories/GHSA-hj7c-g88c-mq5v
security-tracker.debian.org/tracker/CVE-2022-44641