CVE-2015-7801
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code...
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code via a crafted PNG file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code via a crafted PNG file.
- Record
CVE-2015-7801- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Updated
- 2026-11-02
CVE List No score
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code via a crafted PNG file.
- Record
CVE-2015-7801- Updated
- 2026-11-02
EUVDEUVD-2015-7700 No score
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code via a crafted PNG file.
- Record
EUVD-2015-7700- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-76wm-4p7c-3hw9
8.8
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code...
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code via a crafted PNG file.
- Record
GHSA-76wm-4p7c-3hw9- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code via a crafted PNG file.
- Record
CVE-2015-7801- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-7801
8.8
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code via a crafted PNG file.
- Record
DEBIAN-CVE-2015-7801- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-7801
8.8
Use-after-free vulnerability in OptiPNG 0.6.4 allows remote attackers to execute arbitrary code via a crafted PNG file.
- Record
UBUNTU-CVE-2015-7801- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-2951-1 No score
optipng vulnerabilities
Gustavo Grieco discovered that OptiPNG incorrectly handled memory. A remote attacker could use this issue with a specially crafted image file to cause OptiPNG to crash, resulting in a denial of service. (CVE-2015-7801)
Gustavo Grieco discovered that OptiPNG incorrectly handled memory. A remote attacker could use this issue with a specially crafted image file to cause OptiPNG to crash, resulting in a denial of service. (CVE-2015-7802)
Hans Jerry Illikainen discovered that OptiPNG incorrectly handled memory. A remote attacker could use this issue with a specially crafted image file to cause OptiPNG to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-2191)
Henri Salo discovered that OptiPNG incorrectly handled memory. A remote attacker could use this issue with a specially crafted image file to cause OptiPNG to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-3981)
Henri Salo discovered that OptiPNG incorrectly handled memory. A remote attacker could use this issue with a specially crafted image file to cause OptiPNG to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-3982)
- Record
USN-2951-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
optipngDebian:12 |
before 0.7.5-1 | 0.7.5-1 |
optipngDebian:13 |
before 0.7.5-1 | 0.7.5-1 |
optipngDebian:14 |
before 0.7.5-1 | 0.7.5-1 |
optipngDebian:6.0 |
before 0.6.4-1+deb6u11, plus listed versions 0.6.4-1 |
0.6.4-1+deb6u11 |
optipngUbuntu:14.04:LTS |
before 0.6.4-1ubuntu0.14.04.1, plus listed versions 0.6.4-1build1 |
0.6.4-1ubuntu0.14.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-7801 is a high vulnerability (CVSS 8.8) in Optipng Project Optipng, published October 12, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.38%, the 92nd percentile. Fixed in optipng 0.7.5-1.
References
openwall.com/lists/oss-security/2015/09/16/1
bugzilla.redhat.com/show_bug.cgi?id=1264015
ubuntu.com/usn/USN-2951-1
nvd.nist.gov/vuln/detail/CVE-2015-7801
github.com/advisories/GHSA-76wm-4p7c-3hw9
security-tracker.debian.org/tracker/CVE-2015-7801