CVE-2023-33466
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite...
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
- Record
CVE-2023-33466- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
- Record
CVE-2023-33466- Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2023-37629 No score
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
- Record
EUVD-2023-37629- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f5vv-hcgf-xvxq
8.8
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite...
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
- Record
GHSA-f5vv-hcgf-xvxq- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
8.8
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
- Record
CVE-2023-33466- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-33466
8.8
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
- Record
DEBIAN-CVE-2023-33466- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-33466
8.8
Orthanc before 1.12.0 allows authenticated users with access to the Orthanc API to overwrite arbitrary files on the file system, and in specific deployment scenarios allows the attacker to overwrite the configuration, which can be exploited to trigger Remote Code Execution (RCE).
- Record
UBUNTU-CVE-2023-33466- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
orthancDebian:12 |
before 1.10.1+dfsg-2+deb12u1, plus listed versions 1.10.1+dfsg-2 |
1.10.1+dfsg-2+deb12u1 |
orthancDebian:13 |
before 1.12.1+dfsg-1 | 1.12.1+dfsg-1 |
orthancDebian:14 |
before 1.12.1+dfsg-1 | 1.12.1+dfsg-1 |
orthancDebian:10 |
before 1.5.6+dfsg-1+deb10u1, plus listed versions 1.5.6+dfsg-1 |
1.5.6+dfsg-1+deb10u1 |
orthancDebian:11 |
before 1.9.2+really1.9.1+dfsg-1+deb11u1, plus listed versions 1.9.2+really1.9.1+dfsg-1 |
1.9.2+really1.9.1+dfsg-1+deb11u1 |
orthancUbuntu:16.04:LTS |
All versions, plus listed versions 0.9.4+dfsg-10.9.4+dfsg-20.9.5+dfsg-11.0.0+dfsg-11.0.0+dfsg-1build1 |
None known |
orthancUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.0+dfsg-1build11.3.0+dfsg-1build21.3.1+dfsg-11.3.1+dfsg-1build11.3.1+dfsg-1build2 |
None known |
orthancUbuntu:20.04:LTS |
All versions, plus listed versions 1.5.7+dfsg-21.5.8+dfsg-21.5.8+dfsg-2ubuntu21.5.8+dfsg-2ubuntu31.5.8+dfsg-2ubuntu41.5.8+dfsg-2ubuntu51.5.8+dfsg-2ubuntu6 |
None known |
orthancUbuntu:22.04:LTS |
All versions, plus listed versions 1.9.2+really1.9.1+dfsg-11.9.7+dfsg-3ubuntu11.9.7+dfsg-3ubuntu21.9.7+dfsg-41.9.7+dfsg-51.9.7+dfsg-61.10.0+dfsg-1 |
None known |
orthancUbuntu:24.04:LTS |
All versions, plus listed versions 1.12.1+dfsg-31.12.1+dfsg-41.12.1+dfsg-4build11.12.2+dfsg-11.12.2+dfsg-1build31.12.2+dfsg-1build4 |
None known |
orthancUbuntu:25.10 |
All versions, plus listed versions 1.12.6+dfsg-11.12.7+dfsg-41.12.7+dfsg-4build2 |
None known |
orthancUbuntu:26.10 |
All versions, plus listed versions 1.12.10+dfsg-21.12.11+dfsg-81.12.11+dfsg-8build1 |
None known |
orthancUbuntu:26.04:LTS |
All versions, plus listed versions 1.12.7+dfsg-4build21.12.9+dfsg-21.12.10+dfsg-11.12.10+dfsg-1build11.12.10+dfsg-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-33466 is a high vulnerability (CVSS 8.8) in Orthanc-server Orthanc, published June 29, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.15%, the 90th percentile. Fixed in orthanc 1.10.1+dfsg-2+deb12u1.
References
discourse.orthanc-server.org/t/security-advisory-for-orthanc-deployments-running-versions-before-1-12-0/3568
debian.org/security/2023/dsa-5473
lists.debian.org/debian-lts-announce/2023/09/msg00009.html
nvd.nist.gov/vuln/detail/CVE-2023-33466
github.com/advisories/GHSA-f5vv-hcgf-xvxq
security-tracker.debian.org/tracker/CVE-2023-33466
ubuntu.com/security/CVE-2023-33466
cve.org/CVERecord?id=CVE-2023-33466