CVE-2015-8313
GnuTLS incorrectly validates the first byte of padding in CBC modes
GnuTLS incorrectly validates the first byte of padding in CBC modes
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.9
GnuTLS incorrectly validates the first byte of padding in CBC modes
- Record
CVE-2015-8313- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-203
- Updated
- 2026-11-02
CVE List No score
GnuTLS incorrectly validates the first byte of padding in CBC modes
- Record
CVE-2015-8313- Updated
- 2026-11-02
EUVDEUVD-2015-8199 No score
GnuTLS incorrectly validates the first byte of padding in CBC modes
- Record
EUVD-2015-8199- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p72h-2892-8mjc
5.9
GnuTLS incorrectly validates the first byte of padding in CBC modes
GnuTLS incorrectly validates the first byte of padding in CBC modes
- Record
GHSA-p72h-2892-8mjc- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-203
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-8313
5.9
GnuTLS incorrectly validates the first byte of padding in CBC modes
- Record
UBUNTU-CVE-2015-8313- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVSUSE-SU-2016:0077-1 No score
Security update for gnutls
This update for gnutls fixes the following security issues:
- CVE-2015-8313: First byte of the padding in CBC mode is not checked (bsc#957568)
- CVE-2015-2806: Two-byte stack overflow in asn1_der_decoding (bsc#924828)
- Record
SUSE-SU-2016:0077-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gnutls26Debian:6.0 |
before 2.8.6-1+squeeze6, plus listed versions 2.8.6-12.8.6-1+squeeze12.8.6-1+squeeze22.8.6-1+squeeze32.8.6-1+squeeze42.8.6-1+squeeze5 |
2.8.6-1+squeeze6 |
gnutls26Debian:7 |
before 2.12.20-8+deb7u4, plus listed versions 2.12.20-62.12.20-72.12.20-82.12.20-8+deb7u12.12.20-8+deb7u22.12.20-8+deb7u3 |
2.12.20-8+deb7u4 |
gnutlsSUSE:Linux Enterprise Software Development Kit 11 SP3 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise Software Development Kit 11 SP4 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise Desktop 11 SP3 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise Desktop 11 SP4 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise High Availability Extension 11 SP3 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise High Availability Extension 11 SP4 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise Server 11 SP3 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise Server 11 SP3-TERADATA From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
Show 4 moreShow less
| Package | Affected | Fixed |
|---|---|---|
gnutlsSUSE:Linux Enterprise Server for SAP Applications 11 SP3 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise Server 11 SP4 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutlsSUSE:Linux Enterprise Server for SAP Applications 11 SP4 From an advisory covering 2 CVEs |
before 2.4.1-24.39.60.1 | 2.4.1-24.39.60.1 |
gnutls26Ubuntu:14.04:LTS |
before 2.12.23-12ubuntu2.3, plus listed versions 2.12.23-1ubuntu42.12.23-1ubuntu52.12.23-12ubuntu12.12.23-12ubuntu22.12.23-12ubuntu2.12.12.23-12ubuntu2.2 |
2.12.23-12ubuntu2.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-8313 is a medium vulnerability (CVSS 5.9) in Gnu Gnutls, published November 30, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in gnutls26 2.8.6-1+squeeze6.
References
security-tracker.debian.org/tracker/CVE-2015-8313
bugzilla.redhat.com/show_bug.cgi?id=CVE-2015-8313
bugzilla.suse.com/show_bug.cgi?id=CVE-2015-8313
securityfocus.com/bid/78327
debian.org/security/2015/dsa-3408
securityfocus.com/archive/1/537012/100/0/threaded
Show 12 moreShow less
blog.hboeck.de/archives/877-A-little-POODLE-left-in-GnuTLS-old-versions.html
nvd.nist.gov/vuln/detail/CVE-2015-8313
github.com/advisories/GHSA-p72h-2892-8mjc
suse.com/support/update/announcement/2016/suse-su-20160077-1
bugzilla.suse.com/924828
bugzilla.suse.com/947271
bugzilla.suse.com/957568
suse.com/security/cve/CVE-2015-2806
suse.com/security/cve/CVE-2015-8313
ubuntu.com/security/CVE-2015-8313
ubuntu.com/security/notices/USN-2821-1
cve.org/CVERecord?id=CVE-2015-8313