CVE-2020-13574
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP...
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
- Record
CVE-2020-13574- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
EUVDEUVD-2020-5821
7.5
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
- Record
EUVD-2020-5821- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j34q-xv9p-mp65
7.5
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP...
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
- Record
GHSA-j34q-xv9p-mp65- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
NVD
7.5
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
- Record
CVE-2020-13574- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-476
- Updated
- 2026-11-02
OSV
7.5
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
- Record
CVE-2020-13574- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-13574
7.5
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
- Record
DEBIAN-CVE-2020-13574- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-13574
7.5
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
- Record
UBUNTU-CVE-2020-13574- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2021-0263 No score
Updated gsoap packages fix security vulnerabilities
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability (CVE-2020-13574).
A denial-of-service vulnerability exists in the WS-Addressing plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability (CVE-2020-13575).
A code execution vulnerability exists in the WS-Addressing plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to remote code execution. An attacker can send an HTTP request to trigger this vulnerability (CVE-2020-13576).
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability (CVE-2020-13577).
A denial-of-service vulnerability exists in the WS-Security plugin functionality of Genivia gSOAP 2.8.107. A specially crafted SOAP request can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability (CVE-2020-13578).
- Record
MGASA-2021-0263- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gsoapDebian:12 |
before 2.8.104-3 | 2.8.104-3 |
gsoapDebian:13 |
before 2.8.104-3 | 2.8.104-3 |
gsoapDebian:14 |
before 2.8.104-3 | 2.8.104-3 |
gsoapDebian:10 From an advisory covering 5 CVEs |
before 2.8.75-1+deb10u1, plus listed versions 2.8.75-1 |
2.8.75-1+deb10u1 |
gsoapMageia:7 From an advisory covering 5 CVEs |
before 2.8.67-2.1.mga7 | 2.8.67-2.1.mga7 |
gsoapMageia:8 From an advisory covering 5 CVEs |
before 2.8.104-1.1.mga8 | 2.8.104-1.1.mga8 |
gsoapUbuntu:16.04:LTS |
All versions, plus listed versions 2.8.22-12.8.22-22.8.28-1 |
None known |
gsoapUbuntu:18.04:LTS |
All versions, plus listed versions 2.8.49-12.8.60-2build1 |
None known |
gsoapUbuntu:20.04:LTS |
All versions, plus listed versions 2.8.75-22.8.91-2 |
None known |
gsoapUbuntu:22.04:LTS |
All versions, plus listed versions 2.8.104-32.8.117-22.8.117-2build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-13574 is a high vulnerability (CVSS 7.5) in Genivia Gsoap, published February 10, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.08%, the 87th percentile. Fixed in gsoap 2.8.104-3.
References
talosintelligence.com/vulnerability_reports/TALOS-2020-1185
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SMTJ3SJJ22SFLBLPKFADV7NVBH7UFA23
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JINMAJB4WQASTKTNSPQL3V7YMSYPKIA2
lists.debian.org/debian-lts-announce/2024/02/msg00015.html
nvd.nist.gov/vuln/detail/CVE-2020-13574
lists.fedoraproject.org/archives/list/[email protected]/message/JINMAJB4WQASTKTNSPQL3V7YMSYPKIA2
Show 13 moreShow less
lists.fedoraproject.org/archives/list/[email protected]/message/SMTJ3SJJ22SFLBLPKFADV7NVBH7UFA23
github.com/advisories/GHSA-j34q-xv9p-mp65
security-tracker.debian.org/tracker/CVE-2020-13574
advisories.mageia.org/MGASA-2021-0263.html
bugs.mageia.org/show_bug.cgi?id=29015
cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-13574
cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-13575
cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-13576
cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-13577
cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-13578
lists.fedoraproject.org/archives/list/[email protected]/thread/SMTJ3SJJ22SFLBLPKFADV7NVBH7UFA23
ubuntu.com/security/CVE-2020-13574
cve.org/CVERecord?id=CVE-2020-13574