Every CVE Search/ Get API key

CVE-2023-0996

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for...

7.8 HighFix available

CVE-2023-0996 is a high vulnerability (CVSS 7.8) in Struktur Libheif, published February 24, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.31%, the 23rd percentile. Fixed in libheif 1.15.1-1.

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.31%Down 0.6 points since Feb 24, 2023
90%50%10%1%

What each source reports

NVD Score used 7.8

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

Record
CVE-2023-0996
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
CVE List 7.8

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

Record
CVE-2023-0996
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
EUVDEUVD-2023-12980 7.8

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

Record
EUVD-2023-12980
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-3hqh-h748-xjx8 7.8

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for...

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

Record
GHSA-3hqh-h748-xjx8
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
OSV 7.8

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

Record
CVE-2023-0996
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
OSVDEBIAN-CVE-2023-0996 7.8

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

Record
DEBIAN-CVE-2023-0996
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2023-0996 7.8

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

Record
UBUNTU-CVE-2023-0996
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2023-0144 No score

Updated libheif packages fix security vulnerability

Vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call. (CVE-2023-0996)

Record
MGASA-2023-0144
Updated
2026-11-02
OSVopenSUSE-SU-2024:14579-1 No score

gdk-pixbuf-loader-libheif-1.19.5-2.1 on GA media

These are all security issues fixed in the gdk-pixbuf-loader-libheif-1.19.5-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14579-1
Updated
2026-11-02
OSVSUSE-SU-2023:1766-1 No score

Security update for libheif

This update for libheif fixes the following issues:

  • CVE-2023-0996: Fixed a buffer overflow in heif_js_decode_image (bsc#1208640).
Record
SUSE-SU-2023:1766-1
Updated
2026-11-02
OSVUSN-6847-1 No score

libheif vulnerabilities

It was discovered that libheif incorrectly handled certain image data. An attacker could possibly use this issue to crash the program, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS. (CVE-2019-11471)

Reza Mirzazade Farkhani discovered that libheif incorrectly handled certain image data. An attacker could possibly use this issue to crash the program, resulting in a denial of service. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-23109)

Eugene Lim discovered that libheif incorrectly handled certain image data. An attacker could possibly use this issue to crash the program, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2023-0996)

Min Jang discovered that libheif incorrectly handled certain image data. An attacker could possibly use this issue to crash the program, resulting in a denial of service. This issue only affected Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2023-29659)

Yuchuan Meng discovered that libheif incorrectly handled certain image data. An attacker could possibly use this issue to crash the program, resulting in a denial of service. This issue only affected Ubuntu 23.10. (CVE-2023-49460, CVE-2023-49462, CVE-2023-49463, CVE-2023-49464)

Record
USN-6847-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libheif
Debian:12
before 1.15.1-1
1.15.1-1
libheif
Debian:13
before 1.15.1-1
1.15.1-1
libheif
Debian:14
before 1.15.1-1
1.15.1-1
libheif
Debian:11
before 1.11.0-1+deb11u2, plus listed versions
1.11.0-11.11.0-1+deb11u1
1.11.0-1+deb11u2
libheif
Mageia:8
before 1.10.0-1.2.mga8
1.10.0-1.2.mga8
libheif
Mageia:8
before 1.10.0-1.2.mga8.tainted
1.10.0-1.2.mga8.tainted
libheif
SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
before 1.12.0-150400.3.8.1
1.12.0-150400.3.8.1
libheif
openSUSE:Leap 15.4
before 1.12.0-150400.3.8.1
1.12.0-150400.3.8.1
libheif
Ubuntu:Pro:20.04:LTS
before 1.6.1-1ubuntu0.1~esm1, plus listed versions
1.5.0-1build11.5.1-11.5.1-1build11.6.0-11.6.1-11.6.1-1build1
1.6.1-1ubuntu0.1~esm1
libheif
Ubuntu:Pro:22.04:LTS
before 1.12.0-2ubuntu0.1~esm1, plus listed versions
1.11.0-11.12.0-2build1
1.12.0-2ubuntu0.1~esm1
libheif
Ubuntu:Pro:18.04:LTS
before 1.1.0-2ubuntu0.1~esm1, plus listed versions
1.1.0-2
1.1.0-2ubuntu0.1~esm1
libheif
openSUSE:Tumbleweed
before 1.19.5-2.1
1.19.5-2.1

History

History
WhenChangedSources
2026-11-02createdCVE List, EUVD, GitHub Advisories, NVD, OSV

References

Show 19 moreShow less
MoveEnter Open