CVE-2014-8350
Smarty arbitrary PHP code execution
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
Exploit likelihood
What each source reports
NVD Score used
7.5
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
- Record
CVE-2014-8350- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
- Record
CVE-2014-8350- Updated
- 2026-11-02
EUVDEUVD-2022-2026 No score
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
- Record
EUVD-2022-2026- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2pmx-6mm6-6v72 No score
Smarty arbitrary PHP code execution
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
- Record
GHSA-2pmx-6mm6-6v72- Weakness
- CWE-94
- Updated
- 2026-11-02
OSV No score
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
- Record
CVE-2014-8350- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-8350 No score
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
- Record
DEBIAN-CVE-2014-8350- Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-2pmx-6mm6-6v72 No score
Smarty arbitrary PHP code execution
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
- Record
GHSA-2pmx-6mm6-6v72- Weakness
- CWE-94
- Updated
- 2026-11-02
OSVMGASA-2014-0468 No score
Updated php-smarty packages fix security vulnerabilities
Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception (CVE-2012-4437).
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template (CVE-2014-8350).
- Record
MGASA-2014-0468- Updated
- 2026-11-02
OSVMGASA-2014-0469 No score
Updated php-smarty packages fix security vulnerability
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template (CVE-2014-8350).
- Record
MGASA-2014-0469- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-8350 No score
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
- Record
UBUNTU-CVE-2014-8350- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
smarty/smartyPackagist |
before 3.1.21 | 3.1.21 |
smarty3Debian:12 |
before 3.1.21-1 | 3.1.21-1 |
smarty3Debian:13 |
before 3.1.21-1 | 3.1.21-1 |
smarty3Debian:14 |
before 3.1.21-1 | 3.1.21-1 |
smarty3Debian:7 |
before 3.1.10-2+deb7u1, plus listed versions 3.1.10-2 |
3.1.10-2+deb7u1 |
smarty/smartyPackagist |
before 3.1.21, plus listed versions v2.6.24v2.6.25v2.6.26v2.6.27v2.6.28 Show 14 moreShow lessv2.6.29v2.6.30v2.6.31v2.6.33v3.1.11v3.1.12v3.1.13v3.1.14v3.1.15v3.1.16v3.1.17v3.1.18v3.1.19v3.1.20 |
3.1.21 |
php-smartyMageia:3 From an advisory covering 2 CVEs |
before 3.1.21-1.mga3 | 3.1.21-1.mga3 |
php-smartyMageia:4 |
before 3.1.21-1.mga4 | 3.1.21-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-8350 is a high vulnerability (CVSS 7.5) in Smarty, published November 3, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.13%, the 87th percentile. Fixed in smarty/smarty 3.1.21.
References
securityfocus.com/bid/70708
seclists.org/oss-sec/2014/q4/421
code.google.com/p/smarty-php/source/browse/trunk/distribution/change_log.txt?r=4902
advisories.mageia.org/MGASA-2014-0468.html
seclists.org/oss-sec/2014/q4/420
mandriva.com/security/advisories?name=MDVSA-2014:221
Show 11 moreShow less
exchange.xforce.ibmcloud.com/vulnerabilities/97725
bugs.debian.org/cgi-bin/bugreport.cgi?bug=765920
nvd.nist.gov/vuln/detail/CVE-2014-8350
github.com/advisories/GHSA-2pmx-6mm6-6v72
security-tracker.debian.org/tracker/CVE-2014-8350
github.com/smarty-php/smarty
bugs.mageia.org/show_bug.cgi?id=14465
lists.fedoraproject.org/pipermail/package-announce/2014-November/142696.html
advisories.mageia.org/MGASA-2014-0469.html
ubuntu.com/security/CVE-2014-8350
cve.org/CVERecord?id=CVE-2014-8350