Every CVE Search/ Get API key

CVE-2016-4425

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep...

7.5 HighFix available

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.89%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

CVE List 6.5

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.

Record
CVE-2016-4425
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-674
Updated
2026-11-02
EUVDEUVD-2016-5424 6.5

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.

Record
EUVD-2016-5424
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-rf62-m3fm-w623 7.5

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep...

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.

Record
GHSA-rf62-m3fm-w623
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20, CWE-674
Updated
2026-11-02
NVD 6.5

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.

Record
CVE-2016-4425
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20, CWE-674
Updated
2026-11-02
OSV 7.5

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.

Record
CVE-2016-4425
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-4425 7.5

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.

Record
DEBIAN-CVE-2016-4425
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-4425 6.5

Jansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.

Record
UBUNTU-CVE-2016-4425
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2016-0198 No score

Updated jansson packages fix CVE-2016-4425

Updated jansson packages fix security vulnerability:

Gustavo Grieco discovered that jansson did not limit the recursion depth when parsing JSON arrays and objects. This could allow remote attackers to cause a denial of service (crash) via stack exhaustion, using crafted JSON data (CVE-2016-4425).

Record
MGASA-2016-0198
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
jansson
Debian:12
before 2.7-5
2.7-5
jansson
Debian:13
before 2.7-5
2.7-5
jansson
Debian:14
before 2.7-5
2.7-5
jansson
Debian:7
before 2.3.1-2+deb7u1, plus listed versions
2.3.1-2
2.3.1-2+deb7u1
jansson
Debian:8
before 2.7-1+deb8u1, plus listed versions
2.7-1
2.7-1+deb8u1
jansson
Mageia:5
before 2.4-4.1.mga5
2.4-4.1.mga5
jansson
Ubuntu:14.04:LTS
before 2.5-2ubuntu0.1, plus listed versions
2.4-12.5-12.5-1ubuntu12.5-2
2.5-2ubuntu0.1
jansson
Ubuntu:16.04:LTS
before 2.7-3ubuntu0.1, plus listed versions
2.7-1ubuntu12.7-3
2.7-3ubuntu0.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4425 is a high vulnerability (CVSS 7.5) in Jansson Project Jansson, published May 13, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. Fixed in jansson 2.7-5.

References

Show 9 moreShow less
MoveEnter Open