CVE-2014-7912
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before...
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before 5.1 and other products, does not validate the relationship between length fields and the amount of data, which allows remote DHCP servers to execute arbitrary code or cause a denial of service (memory corruption) via a large length value of an option in a DHCPACK message.
Exploit likelihood
What each source reports
NVD Score used
6.8
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before 5.1 and other products, does not validate the relationship between length fields and the amount of data, which allows remote DHCP servers to execute arbitrary code or cause a denial of service (memory corruption) via a large length value of an option in a DHCPACK message.
- Record
CVE-2014-7912- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before 5.1 and other products, does not validate the relationship between length fields and the amount of data, which allows remote DHCP servers to execute arbitrary code or cause a denial of service (memory corruption) via a large length value of an option in a DHCPACK message.
- Record
CVE-2014-7912- Updated
- 2026-11-02
EUVDEUVD-2014-7762 No score
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before 5.1 and other products, does not validate the relationship between length fields and the amount of data, which allows remote DHCP servers to execute arbitrary code or cause a denial of service (memory corruption) via a large length value of an option in a DHCPACK message.
- Record
EUVD-2014-7762- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f6q4-hgr5-frj4 No score
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before...
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before 5.1 and other products, does not validate the relationship between length fields and the amount of data, which allows remote DHCP servers to execute arbitrary code or cause a denial of service (memory corruption) via a large length value of an option in a DHCPACK message.
- Record
GHSA-f6q4-hgr5-frj4- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before 5.1 and other products, does not validate the relationship between length fields and the amount of data, which allows remote DHCP servers to execute arbitrary code or cause a denial of service (memory corruption) via a large length value of an option in a DHCPACK message.
- Record
CVE-2014-7912- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-7912 No score
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before 5.1 and other products, does not validate the relationship between length fields and the amount of data, which allows remote DHCP servers to execute arbitrary code or cause a denial of service (memory corruption) via a large length value of an option in a DHCPACK message.
- Record
DEBIAN-CVE-2014-7912- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-7912 No score
The get_option function in dhcp.c in dhcpcd before 6.2.0, as used in dhcpcd 5.x in Android before 5.1 and other products, does not validate the relationship between length fields and the amount of data, which allows remote DHCP servers to execute arbitrary code or cause a denial of service (memory corruption) via a large length value of an option in a DHCPACK message.
- Record
UBUNTU-CVE-2014-7912- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dhcpcd5Debian:12 |
before 6.9.1-1 | 6.9.1-1 |
dhcpcd5Debian:7 From an advisory covering 2 CVEs |
before 5.5.6-1+deb7u2, plus listed versions 5.5.6-15.5.6-1+deb7u1 |
5.5.6-1+deb7u2 |
dhcpcd5Ubuntu:Pro:14.04:LTS |
All versions, plus listed versions 5.5.6-16.0.5-1ubuntu16.0.5-1.16.0.5-2build0.14.04.16.0.5-2+deb8u1build0.14.04.1~esm1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | vaginessa/cve-2014-7912 | 2017-11-22 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-7912 is a medium vulnerability (CVSS 6.8) in Dhcpcd Project Dhcpcd, published July 30, 2015. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.65%, the 85th percentile. Fixed in dhcpcd5 6.9.1-1.
References
securitytracker.com/id/1033124
zerodayinitiative.com/advisories/ZDI-15-093
android.googlesource.com/platform/external/dhcpcd/+/73c09dd8067250734511d955d8f792b41c7213f0
nvd.nist.gov/vuln/detail/CVE-2014-7912
github.com/advisories/GHSA-f6q4-hgr5-frj4
security-tracker.debian.org/tracker/CVE-2014-7912
ubuntu.com/security/CVE-2014-7912
cve.org/CVERecord?id=CVE-2014-7912