CVE-2014-9497
Buffer overflow in mpg123 before 1.18.0.
7.5 HighFix available
Buffer overflow in mpg123 before 1.18.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
2.29%Up 1.3 points since Feb 4, 2022
What each source reports
NVD Score used
7.5
Buffer overflow in mpg123 before 1.18.0.
- Record
CVE-2014-9497- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Buffer overflow in mpg123 before 1.18.0.
- Record
CVE-2014-9497- Updated
- 2026-11-02
EUVDEUVD-2014-9314 No score
Buffer overflow in mpg123 before 1.18.0.
- Record
EUVD-2014-9314- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fpx3-552f-qj3v
7.5
Buffer overflow in mpg123 before 1.18.0.
Buffer overflow in mpg123 before 1.18.0.
- Record
GHSA-fpx3-552f-qj3v- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.5
Buffer overflow in mpg123 before 1.18.0.
- Record
CVE-2014-9497- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-9497
7.5
Buffer overflow in mpg123 before 1.18.0.
- Record
DEBIAN-CVE-2014-9497- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-9497
7.5
Buffer overflow in mpg123 before 1.18.0.
- Record
UBUNTU-CVE-2014-9497- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mpg123Debian:12 |
before 1.18.0-1 | 1.18.0-1 |
mpg123Debian:13 |
before 1.18.0-1 | 1.18.0-1 |
mpg123Debian:14 |
before 1.18.0-1 | 1.18.0-1 |
mpg123Debian:7 From an advisory covering 2 CVEs |
before 1.14.4-1+deb7u1, plus listed versions 1.14.4-1 |
1.14.4-1+deb7u1 |
mpg123Ubuntu:14.04:LTS |
before 1.16.0-1ubuntu1.1, plus listed versions 1.15.3-1ubuntu11.16.0-1ubuntu1 |
1.16.0-1ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-9497 is a high vulnerability (CVSS 7.5) in Mpg123, published October 15, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.29%, the 83rd percentile. Fixed in mpg123 1.18.0-1.
References
sourceforge.net/p/mpg123/bugs/201
security.gentoo.org/glsa/201502-01
openwall.com/lists/oss-security/2015/01/04/5
nvd.nist.gov/vuln/detail/CVE-2014-9497
github.com/advisories/GHSA-fpx3-552f-qj3v
security-tracker.debian.org/tracker/CVE-2014-9497
ubuntu.com/security/CVE-2014-9497
cve.org/CVERecord?id=CVE-2014-9497