Every CVE Search/ Get API key

CVE-2014-8716

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service ...

6.2 MediumFix available

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service (out-of-bounds memory access and crash).

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.40%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.2

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service (out-of-bounds memory access and crash).

Record
CVE-2014-8716
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service (out-of-bounds memory access and crash).

Record
CVE-2014-8716
Updated
2026-11-02
EUVDEUVD-2014-8548 No score

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service (out-of-bounds memory access and crash).

Record
EUVD-2014-8548
Updated
2026-11-03
GitHub AdvisoriesGHSA-q8px-58hp-6wh5 6.2

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service ...

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service (out-of-bounds memory access and crash).

Record
GHSA-q8px-58hp-6wh5
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 6.2

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service (out-of-bounds memory access and crash).

Record
CVE-2014-8716
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-8716 6.2

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service (out-of-bounds memory access and crash).

Record
DEBIAN-CVE-2014-8716
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2014-8716 6.2

The JPEG decoder in ImageMagick before 6.8.9-9 allows local users to cause a denial of service (out-of-bounds memory access and crash).

Record
UBUNTU-CVE-2014-8716
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2014-0482 No score

Updated imagemagick packages fix security vulnerabilities

ImageMagick is vulnerable to a denial of service due to out-of-bounds memory accesses in the resize code (CVE-2014-8354), PCX parser (CVE-2014-8355), DCM decoder (CVE-2014-8562), and JPEG decoder (CVE-2014-8716).

Record
MGASA-2014-0482
Updated
2026-11-02
OSVUSN-3131-1 No score

imagemagick vulnerabilities

It was discovered that ImageMagick incorrectly handled certain malformed image files. If a user or automated system using ImageMagick were tricked into opening a specially crafted image, an attacker could exploit this to cause a denial of service or possibly execute code with the privileges of the user invoking the program.

Record
USN-3131-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
imagemagick
Debian:12
before 8:6.8.9.9-3
8:6.8.9.9-3
imagemagick
Debian:13
before 8:6.8.9.9-3
8:6.8.9.9-3
imagemagick
Debian:14
before 8:6.8.9.9-3
8:6.8.9.9-3
imagemagick
Debian:6.0
before 8:6.6.0.4-3+squeeze5, plus listed versions
8:6.6.0.4-38:6.6.0.4-3+squeeze18:6.6.0.4-3+squeeze28:6.6.0.4-3+squeeze38:6.6.0.4-3+squeeze4
8:6.6.0.4-3+squeeze5
imagemagick
Debian:7
From an advisory covering 33 CVEs
before 8:6.7.7.10-5+deb7u13, plus listed versions
8:6.7.7.10-58:6.7.7.10-5+deb7u108:6.7.7.10-5+deb7u118:6.7.7.10-5+deb7u128:6.7.7.10-5+deb7u2
Show 7 moreShow less
8:6.7.7.10-5+deb7u38:6.7.7.10-5+deb7u48:6.7.7.10-5+deb7u58:6.7.7.10-5+deb7u68:6.7.7.10-5+deb7u78:6.7.7.10-5+deb7u88:6.7.7.10-5+deb7u9
8:6.7.7.10-5+deb7u13
imagemagick
Mageia:3
From an advisory covering 4 CVEs
before 6.8.1.1-2.3.mga3
6.8.1.1-2.3.mga3
imagemagick
Mageia:4
From an advisory covering 4 CVEs
before 6.8.7.0-2.3.mga4
6.8.7.0-2.3.mga4
imagemagick
Ubuntu:14.04:LTS
before 8:6.7.7.10-6ubuntu3.2, plus listed versions
8:6.7.7.10-5ubuntu38:6.7.7.10-5ubuntu48:6.7.7.10-6ubuntu18:6.7.7.10-6ubuntu28:6.7.7.10-6ubuntu38:6.7.7.10-6ubuntu3.1
8:6.7.7.10-6ubuntu3.2
imagemagick
Ubuntu:14.04:LTS
From an advisory covering 103 CVEs
before 8:6.7.7.10-6ubuntu3.2, plus listed versions
8:6.7.7.10-5ubuntu38:6.7.7.10-5ubuntu48:6.7.7.10-6ubuntu18:6.7.7.10-6ubuntu28:6.7.7.10-6ubuntu38:6.7.7.10-6ubuntu3.1
8:6.7.7.10-6ubuntu3.2
imagemagick
Ubuntu:16.04:LTS
From an advisory covering 103 CVEs
before 8:6.8.9.9-7ubuntu5.2, plus listed versions
8:6.8.9.9-5ubuntu28:6.8.9.9-68:6.8.9.9-6build18:6.8.9.9-78:6.8.9.9-7ubuntu1
Show 5 moreShow less
8:6.8.9.9-7ubuntu28:6.8.9.9-7ubuntu38:6.8.9.9-7ubuntu48:6.8.9.9-7ubuntu58:6.8.9.9-7ubuntu5.1
8:6.8.9.9-7ubuntu5.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-8716 is a medium vulnerability (CVSS 6.2) in Imagemagick, published November 12, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in imagemagick 8:6.8.9.9-3.

References

Show 108 moreShow less
MoveEnter Open