CVE-2017-7467
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape...
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.0
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
- Record
CVE-2017-7467- CVSS 3.0
- 7.0 High
CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2017-16490
7.0
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
- Record
EUVD-2017-16490- CVSS 3.0
- 7.0 High
CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-526f-cp8m-4xjp
9.8
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape...
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
- Record
GHSA-526f-cp8m-4xjp- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
NVD
7.0
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
- Record
CVE-2017-7467- CVSS 3.0
- 7.0 High
CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-787, CWE-119
- Updated
- 2026-11-02
OSV
9.8
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
- Record
CVE-2017-7467- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-7467
9.8
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
- Record
DEBIAN-CVE-2017-7467- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2017-7467
9.8
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
- Record
UBUNTU-CVE-2017-7467- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.0 High
CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0128 No score
Updated minicom packages fix security vulnerability
In minicom before version 2.7.1, the escparms[] buffer in vt100.c is vulnerable to an overflow that may allow for remote code execution (CVE-2017-7467).
- Record
MGASA-2017-0128- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11049-1 No score
minicom-2.7.1-2.9 on GA media
These are all security issues fixed in the minicom-2.7.1-2.9 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11049-1- Updated
- 2026-11-02
OSVSUSE-SU-2017:1092-1 No score
Security update for minicom
This update for minicom fixes the following issue:
This security issue was fixed:
- CVE-2017-7467: Invalid cursor coordinates and scroll regions could lead to code execution (bsc#1033783).
- Record
SUSE-SU-2017:1092-1- Updated
- 2026-11-02
OSVSUSE-SU-2017:1136-1 No score
Security update for minicom
This update for minicom fixes the following issues:
- CVE-2017-7467: Invalid cursor coordinates and scroll regions could lead to code execution (bsc#1033783)
- Record
SUSE-SU-2017:1136-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
minicomDebian:12 |
before 2.7-1.1 | 2.7-1.1 |
minicomDebian:13 |
before 2.7-1.1 | 2.7-1.1 |
minicomDebian:14 |
before 2.7-1.1 | 2.7-1.1 |
minicomDebian:7 |
before 2.6.1-1+deb7u1, plus listed versions 2.6.1-1 |
2.6.1-1+deb7u1 |
minicomMageia:5 |
before 2.7.1-1.mga5 | 2.7.1-1.mga5 |
minicomSUSE:Linux Enterprise Desktop 12 SP1 |
before 2.7-3.1 | 2.7-3.1 |
minicomSUSE:Linux Enterprise Desktop 12 SP2 |
before 2.7-3.1 | 2.7-3.1 |
minicomSUSE:Linux Enterprise Server for Raspberry Pi 12 SP2 |
before 2.7-3.1 | 2.7-3.1 |
minicomSUSE:Linux Enterprise Server 12 SP1 |
before 2.7-3.1 | 2.7-3.1 |
minicomSUSE:Linux Enterprise Server for SAP Applications 12 SP1 |
before 2.7-3.1 | 2.7-3.1 |
Show 7 moreShow less
| Package | Affected | Fixed |
|---|---|---|
minicomSUSE:Linux Enterprise Server 12 SP2 |
before 2.7-3.1 | 2.7-3.1 |
minicomSUSE:Linux Enterprise Server for SAP Applications 12 SP2 |
before 2.7-3.1 | 2.7-3.1 |
minicomSUSE:Linux Enterprise Server 11 SP4 |
before 2.3-27.24.6.2 | 2.3-27.24.6.2 |
minicomSUSE:Linux Enterprise Server for SAP Applications 11 SP4 |
before 2.3-27.24.6.2 | 2.3-27.24.6.2 |
minicomUbuntu:14.04:LTS |
before 2.7-1+deb8u1build0.14.04.1, plus listed versions 2.6.2-12.7-1 |
2.7-1+deb8u1build0.14.04.1 |
minicomUbuntu:16.04:LTS |
before 2.7-1+deb8u1build0.16.04.1, plus listed versions 2.7-12.7-1build1 |
2.7-1+deb8u1build0.16.04.1 |
minicomopenSUSE:Tumbleweed |
before 2.7.1-2.9 | 2.7.1-2.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-7467 is a high vulnerability (CVSS 7.0) in [unknown] Minicom, published April 21, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.70%, the 85th percentile. Fixed in minicom 2.7-1.1.
References
openwall.com/lists/oss-security/2017/04/18/5
securityfocus.com/bid/97966
bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7467
security.gentoo.org/glsa/201706-13
nvd.nist.gov/vuln/detail/CVE-2017-7467
github.com/advisories/GHSA-526f-cp8m-4xjp
Show 9 moreShow less
security-tracker.debian.org/tracker/CVE-2017-7467
advisories.mageia.org/MGASA-2017-0128.html
bugs.mageia.org/show_bug.cgi?id=20701
suse.com/support/update/announcement/2017/suse-su-20171092-1
bugzilla.suse.com/1033783
suse.com/security/cve/CVE-2017-7467
suse.com/support/update/announcement/2017/suse-su-20171136-1
ubuntu.com/security/CVE-2017-7467
cve.org/CVERecord?id=CVE-2017-7467