Every CVE Search/ Get API key

CVE-2004-2043

Buffer overflow in ibserver for Firebird Database 1.0 and other versions before 1.5, and possibly...

5.0 MediumPublic exploitFix available

Buffer overflow in ibserver for Firebird Database 1.0 and other versions before 1.5, and possibly other products that use the InterBase codebase, allows remote attackers to cause a denial of service (crash) via a long database name, as demonstrated using the gsec command.

Exploit likelihood

11.9%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Buffer overflow in ibserver for Firebird Database 1.0 and other versions before 1.5, and possibly other products that use the InterBase codebase, allows remote attackers to cause a denial of service (crash) via a long database name, as demonstrated using the gsec command.

Record
CVE-2004-2043
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in ibserver for Firebird Database 1.0 and other versions before 1.5, and possibly other products that use the InterBase codebase, allows remote attackers to cause a denial of service (crash) via a long database name, as demonstrated using the gsec command.

Record
CVE-2004-2043
Updated
2026-11-02
EUVDEUVD-2004-2035 No score

Buffer overflow in ibserver for Firebird Database 1.0 and other versions before 1.5, and possibly other products that use the InterBase codebase, allows remote attackers to cause a denial of service (crash) via a long database name, as demonstrated using the gsec command.

Record
EUVD-2004-2035
Updated
2026-11-03
GitHub AdvisoriesGHSA-grgp-hrrx-jxvp No score

Buffer overflow in ibserver for Firebird Database 1.0 and other versions before 1.5, and possibly...

Buffer overflow in ibserver for Firebird Database 1.0 and other versions before 1.5, and possibly other products that use the InterBase codebase, allows remote attackers to cause a denial of service (crash) via a long database name, as demonstrated using the gsec command.

Record
GHSA-grgp-hrrx-jxvp
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
firebird2
Debian:3.1
before 1.5.1-4sarge1, plus listed versions
1.5.1-4
1.5.1-4sarge1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBFirebird 1.0 - Remote Database Name Buffer Overrun2004-06-01
Exploit-DBBorland Interbase 7.x - Remote Buffer Overflow2004-06-25

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-2043 is a medium vulnerability (CVSS 5.0) in Borland Software Interbase, published May 1, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.9%, the 96th percentile. Fixed in firebird2 1.5.1-4sarge1.

References

Show 8 moreShow less
MoveEnter Open