CVE-2005-2781
The Avatar upload feature in FUD Forum before 2.7.0 does not properly verify uploaded files,...
The Avatar upload feature in FUD Forum before 2.7.0 does not properly verify uploaded files, which allows remote attackers to execute arbitrary PHP code via a file with a .php extension that contains image data followed by PHP code.
Exploit likelihood
What each source reports
NVD Score used
7.5
The Avatar upload feature in FUD Forum before 2.7.0 does not properly verify uploaded files, which allows remote attackers to execute arbitrary PHP code via a file with a .php extension that contains image data followed by PHP code.
- Record
CVE-2005-2781- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
The Avatar upload feature in FUD Forum before 2.7.0 does not properly verify uploaded files, which allows remote attackers to execute arbitrary PHP code via a file with a .php extension that contains image data followed by PHP code.
- Record
CVE-2005-2781- Updated
- 2026-11-02
EUVDEUVD-2005-2782 No score
The Avatar upload feature in FUD Forum before 2.7.0 does not properly verify uploaded files, which allows remote attackers to execute arbitrary PHP code via a file with a .php extension that contains image data followed by PHP code.
- Record
EUVD-2005-2782- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m2hw-cx9w-5jj2 No score
The Avatar upload feature in FUD Forum before 2.7.0 does not properly verify uploaded files,...
The Avatar upload feature in FUD Forum before 2.7.0 does not properly verify uploaded files, which allows remote attackers to execute arbitrary PHP code via a file with a .php extension that contains image data followed by PHP code.
- Record
GHSA-m2hw-cx9w-5jj2- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpgroupwareDebian:3.0 |
before 0.9.14-0.RC3.2.woody6, plus listed versions 0.9.14-0.RC3.2.woody30.9.14-0.RC3.2.woody40.9.14-0.RC3.2.woody5 |
0.9.14-0.RC3.2.woody6 |
phpgroupwareDebian:3.1 |
before 0.9.16.005-3.sarge5, plus listed versions 0.9.16.005-30.9.16.005-3.sarge00.9.16.005-3.sarge10.9.16.005-3.sarge20.9.16.005-3.sarge30.9.16.005-3.sarge4 |
0.9.16.005-3.sarge5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-2781 is a high vulnerability (CVSS 7.5) in Ilia Alshanetsky Fudforum, published September 2, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. Fixed in phpgroupware 0.9.14-0.RC3.2.woody6.