CVE-2006-4305
Buffer overflow in SAP DB and MaxDB before 7.6.00.30 allows remote attackers to execute arbitrary...
Buffer overflow in SAP DB and MaxDB before 7.6.00.30 allows remote attackers to execute arbitrary code via a long database name when connecting via a WebDBM client.
Exploit likelihood
What each source reports
NVD Score used
10.0
Buffer overflow in SAP DB and MaxDB before 7.6.00.30 allows remote attackers to execute arbitrary code via a long database name when connecting via a WebDBM client.
- Record
CVE-2006-4305- CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Updated
- 2026-11-02
CVE List No score
Buffer overflow in SAP DB and MaxDB before 7.6.00.30 allows remote attackers to execute arbitrary code via a long database name when connecting via a WebDBM client.
- Record
CVE-2006-4305- Updated
- 2026-11-02
EUVDEUVD-2006-4293 No score
Buffer overflow in SAP DB and MaxDB before 7.6.00.30 allows remote attackers to execute arbitrary code via a long database name when connecting via a WebDBM client.
- Record
EUVD-2006-4293- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-88j9-hr3g-c3jw No score
Buffer overflow in SAP DB and MaxDB before 7.6.00.30 allows remote attackers to execute arbitrary...
Buffer overflow in SAP DB and MaxDB before 7.6.00.30 allows remote attackers to execute arbitrary code via a long database name when connecting via a WebDBM client.
- Record
GHSA-88j9-hr3g-c3jw- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
maxdb-7.5.00Debian:3.1 |
before 7.5.00.24-4, plus listed versions 7.5.00.24-3 |
7.5.00.24-4 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | MaxDB WebDBM - 'Database' Remote Overflow (Metasploit) | 2010-09-20 |
| Metasploit | MaxDB WebDBM Database Parameter Overflow | 2006-08-29 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-4305 is a high vulnerability (CVSS 10.0) in Mysql Maxdb, published August 30, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 71.7%, the 99th percentile. Fixed in maxdb-7.5.00 7.5.00.24-4.