Every CVE Search/ Get API key

CVE-2006-5864

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly...

5.1 MediumPublic exploitFix available

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly earlier versions, allows user-assisted attackers to execute arbitrary code via a PostScript (PS) file with certain headers that contain long comments, as demonstrated using the (1) DocumentMedia, (2) DocumentPaperSizes, and possibly (3) PageMedia and (4) PaperSize headers. NOTE: this issue can be exploited through other products that use gv such as evince.

Exploit likelihood

16.1%Down 11.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly earlier versions, allows user-assisted attackers to execute arbitrary code via a PostScript (PS) file with certain headers that contain long comments, as demonstrated using the (1) DocumentMedia, (2) DocumentPaperSizes, and possibly (3) PageMedia and (4) PaperSize headers. NOTE: this issue can be exploited through other products that use gv such as evince.

Record
CVE-2006-5864
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly earlier versions, allows user-assisted attackers to execute arbitrary code via a PostScript (PS) file with certain headers that contain long comments, as demonstrated using the (1) DocumentMedia, (2) DocumentPaperSizes, and possibly (3) PageMedia and (4) PaperSize headers. NOTE: this issue can be exploited through other products that use gv such as evince.

Record
CVE-2006-5864
Updated
2026-11-02
EUVDEUVD-2006-5848 No score

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly earlier versions, allows user-assisted attackers to execute arbitrary code via a PostScript (PS) file with certain headers that contain long comments, as demonstrated using the (1) DocumentMedia, (2) DocumentPaperSizes, and possibly (3) PageMedia and (4) PaperSize headers. NOTE: this issue can be exploited through other products that use gv such as evince.

Record
EUVD-2006-5848
Updated
2026-11-03
GitHub AdvisoriesGHSA-c7wv-85x6-hmhm No score

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly...

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly earlier versions, allows user-assisted attackers to execute arbitrary code via a PostScript (PS) file with certain headers that contain long comments, as demonstrated using the (1) DocumentMedia, (2) DocumentPaperSizes, and possibly (3) PageMedia and (4) PaperSize headers. NOTE: this issue can be exploited through other products that use gv such as evince.

Record
GHSA-c7wv-85x6-hmhm
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly earlier versions, allows user-assisted attackers to execute arbitrary code via a PostScript (PS) file with certain headers that contain long comments, as demonstrated using the (1) DocumentMedia, (2) DocumentPaperSizes, and possibly (3) PageMedia and (4) PaperSize headers. NOTE: this issue can be exploited through other products that use gv such as evince.

Record
CVE-2006-5864
Updated
2026-11-02
OSVDEBIAN-CVE-2006-5864 No score

Stack-based buffer overflow in the ps_gettext function in ps.c for GNU gv 3.6.2, and possibly earlier versions, allows user-assisted attackers to execute arbitrary code via a PostScript (PS) file with certain headers that contain long comments, as demonstrated using the (1) DocumentMedia, (2) DocumentPaperSizes, and possibly (3) PageMedia and (4) PaperSize headers. NOTE: this issue can be exploited through other products that use gv such as evince.

Record
DEBIAN-CVE-2006-5864
Updated
2026-11-02
OSVopenSUSE-SU-2024:10742-1 No score

evince-40.4-1.3 on GA media

These are all security issues fixed in the evince-40.4-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10742-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
evince
Debian:12
before 0.4.0-3
0.4.0-3
evince
Debian:13
before 0.4.0-3
0.4.0-3
gv
Debian:12
before 1:3.6.2-3
1:3.6.2-3
gv
Debian:13
before 1:3.6.2-3
1:3.6.2-3
gv
Debian:14
before 1:3.6.2-3
1:3.6.2-3
gv
Debian:3.1
before 1:3.6.1-10sarge1, plus listed versions
1:3.6.1-10
1:3.6.1-10sarge1
gv
Debian:3.1
before 1:3.6.1-10sarge2, plus listed versions
1:3.6.1-101:3.6.1-10sarge1
1:3.6.1-10sarge2
evince
Debian:3.1
before 0.1.5-2sarge1, plus listed versions
0.1.5-2
0.1.5-2sarge1
evince
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 40.4-1.3
40.4-1.3

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBEvince Document Viewer - 'DocumentMedia' Remote Buffer Overflow2006-11-28

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-5864 is a medium vulnerability (CVSS 5.1) in Gnu Gv, published November 11, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 16.1%, the 96th percentile. Fixed in evince 0.4.0-3.

References

Show 40 moreShow less
MoveEnter Open