Every CVE Search/ Get API key

CVE-2008-0047

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions...

9.3 HighFix available

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions including the version bundled with Apple Mac OS X 10.5.2, when printer sharing is enabled, allows remote attackers to execute arbitrary code via crafted search expressions.

Exploit likelihood

6.77%Down 3.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions including the version bundled with Apple Mac OS X 10.5.2, when printer sharing is enabled, allows remote attackers to execute arbitrary code via crafted search expressions.

Record
CVE-2008-0047
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions including the version bundled with Apple Mac OS X 10.5.2, when printer sharing is enabled, allows remote attackers to execute arbitrary code via crafted search expressions.

Record
CVE-2008-0047
Updated
2026-11-02
EUVDEUVD-2008-0060 No score

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions including the version bundled with Apple Mac OS X 10.5.2, when printer sharing is enabled, allows remote attackers to execute arbitrary code via crafted search expressions.

Record
EUVD-2008-0060
Updated
2026-11-03
GitHub AdvisoriesGHSA-955r-8v94-5rcf No score

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions...

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions including the version bundled with Apple Mac OS X 10.5.2, when printer sharing is enabled, allows remote attackers to execute arbitrary code via crafted search expressions.

Record
GHSA-955r-8v94-5rcf
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions including the version bundled with Apple Mac OS X 10.5.2, when printer sharing is enabled, allows remote attackers to execute arbitrary code via crafted search expressions.

Record
CVE-2008-0047
Updated
2026-11-02
OSVDEBIAN-CVE-2008-0047 No score

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions including the version bundled with Apple Mac OS X 10.5.2, when printer sharing is enabled, allows remote attackers to execute arbitrary code via crafted search expressions.

Record
DEBIAN-CVE-2008-0047
Updated
2026-11-02
OSVopenSUSE-SU-2024:10707-1 No score

cups-2.3.3op2-4.2 on GA media

These are all security issues fixed in the cups-2.3.3op2-4.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10707-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cups
Debian:12
before 1.3.6-3
1.3.6-3
cups
Debian:13
before 1.3.6-3
1.3.6-3
cups
Debian:14
before 1.3.6-3
1.3.6-3
cupsys
Debian:4.0
before 1.2.7-4etch3, plus listed versions
1.2.7-41.2.7-4etch11.2.7-4etch2
1.2.7-4etch3
cups
Red Hat:enterprise_linux:5::client_workstation
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-devel
Red Hat:enterprise_linux:5::client_workstation
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups
Red Hat:enterprise_linux:5::client
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-debuginfo
Red Hat:enterprise_linux:5::client
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-devel
Red Hat:enterprise_linux:5::client
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
Show 8 moreShow less
Affected packages
PackageAffectedFixed
cups-libs
Red Hat:enterprise_linux:5::client
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-lpd
Red Hat:enterprise_linux:5::client
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups
Red Hat:enterprise_linux:5::server
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-debuginfo
Red Hat:enterprise_linux:5::server
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-devel
Red Hat:enterprise_linux:5::server
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-libs
Red Hat:enterprise_linux:5::server
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups-lpd
Red Hat:enterprise_linux:5::server
before 1:1.2.4-11.14.el5_1.6
1:1.2.4-11.14.el5_1.6
cups
openSUSE:Tumbleweed
before 2.3.3op2-4.2
2.3.3op2-4.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-0047 is a high vulnerability (CVSS 9.3) in Cups, published March 18, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.77%, the 94th percentile. Fixed in cups 1.3.6-3.

References

Show 57 moreShow less
MoveEnter Open